summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/factory_boy/factory_boy-1.1.3.ebuild')
-rw-r--r--dev-python/factory_boy/factory_boy-1.1.3.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/dev-python/factory_boy/factory_boy-1.1.3.ebuild b/dev-python/factory_boy/factory_boy-1.1.3.ebuild
index 150e4d11b..f8570e034 100644
--- a/dev-python/factory_boy/factory_boy-1.1.3.ebuild
+++ b/dev-python/factory_boy/factory_boy-1.1.3.ebuild
@@ -2,12 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=4
PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
inherit distutils
DESCRIPTION="A versatile test fixtures replacement"
@@ -17,7 +19,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc"
+IUSE="doc test"
RDEPEND=""
DEPEND="doc? ( dev-python/sphinx )"
@@ -27,21 +29,14 @@ src_compile() {
if use doc; then
einfo "Generation of documentation"
- emake -C docs html || die "Generation of documentation failed"
+ emake -C docs html
fi
}
-src_test() {
- testing() {
- "$(PYTHON)" setup.py test || return 1
- }
- python_execute_function testing
-}
-
src_install() {
distutils_src_install
if use doc; then
- dohtml -r -A txt docs/_build/html/* || die "Installation of documentation failed"
+ dohtml -r -A txt docs/_build/html/*
fi
}