summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_skey/pam_skey-1.1.5.ebuild')
-rw-r--r--sys-auth/pam_skey/pam_skey-1.1.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-auth/pam_skey/pam_skey-1.1.5.ebuild b/sys-auth/pam_skey/pam_skey-1.1.5.ebuild
new file mode 100644
index 000000000..3ac016ffd
--- /dev/null
+++ b/sys-auth/pam_skey/pam_skey-1.1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils pam
+
+DESCRIPTION="pam interface to existing S/Key library/interface"
+HOMEPAGE="http://freshmeat.net/projects/pam_skey/"
+SRC_URI="http://kreator.esa.fer.hr/projects/tarballs/${P}.tar.gz"
+ #http://dchurch.ath.cx/${P}-gentoo-${PR}.patch.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=sys-libs/pam-0.78-r3
+ >=app-admin/skey-1.1.5-r4"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ econf --libdir="/lib" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README INSTALL
+ newpamd ${FILESDIR}/pam_skey-system-auth.pam.d system-auth
+}