summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/dragbox/dragbox-0.4.0.ebuild')
-rw-r--r--x11-misc/dragbox/dragbox-0.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/dragbox/dragbox-0.4.0.ebuild b/x11-misc/dragbox/dragbox-0.4.0.ebuild
new file mode 100644
index 000000000..d6100d02d
--- /dev/null
+++ b/x11-misc/dragbox/dragbox-0.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit python
+
+DESCRIPTION="Dragbox is a GTK tool for connecting the commandline with the desktop environment."
+HOMEPAGE="http://kaizer.se/wiki/dragbox/"
+SRC_URI="http://kaizer.se/publicfiles/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/pygtk
+ gnome-base/libglade
+ sys-apps/dbus
+ x11-libs/gtk+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/Dragbox
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/Dragbox
+}