summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/kinect-mouse/kinect-mouse-0_p20101210.ebuild')
-rw-r--r--x11-misc/kinect-mouse/kinect-mouse-0_p20101210.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/kinect-mouse/kinect-mouse-0_p20101210.ebuild b/x11-misc/kinect-mouse/kinect-mouse-0_p20101210.ebuild
new file mode 100644
index 000000000..8425a9dd3
--- /dev/null
+++ b/x11-misc/kinect-mouse/kinect-mouse-0_p20101210.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit cmake-utils
+
+DESCRIPTION="A program that uses the libfreenect drivers to control mouse input"
+HOMEPAGE="https://github.com/Ooblik/Kinect-Mouse"
+SRC_URI="http://ompldr.org/vNzRldA/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/freeglut
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXtst
+ x11-drivers/libfreenect"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ elog "To start using the kinect as a mouse, execute the kmouse program."
+ elog "The kmouse program performs a left click when you hold the "
+ elog "cursor over something for a few seconds."
+}