summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xgestures/xgestures-0.4-r1.ebuild')
-rw-r--r--x11-misc/xgestures/xgestures-0.4-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/xgestures/xgestures-0.4-r1.ebuild b/x11-misc/xgestures/xgestures-0.4-r1.ebuild
new file mode 100644
index 000000000..8ebb19d35
--- /dev/null
+++ b/x11-misc/xgestures/xgestures-0.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A mouse gesture recognition program for X11 desktops"
+HOMEPAGE="http://www.cs.bgu.ac.il/~tzachar/xgestures.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed!"
+ dodoc README NEWS AUTHORS ChangeLog
+ newdoc .gestures gestures
+ echo
+ elog "Copy file /usr/share/doc/${PF}/gestures to \$HOME/.gestures"
+ echo
+}
+