summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-03-14 15:33:02 -0700
committerMike Frysinger <vapier@gentoo.org>2017-03-14 15:33:02 -0700
commitc0a2c3677f32cd7e75143d35f77873530ddde258 (patch)
treef186bfb68c39c99dd806123d5a31aca32179c663
parentgcc: move old 5.[123] versions from the main tree (diff)
downloadtoolchain-c0a2c367.tar.gz
toolchain-c0a2c367.tar.bz2
toolchain-c0a2c367.zip
gcc: migrate all ebuilds to EAPI=5
-rw-r--r--sys-devel/gcc/gcc-4.0.0.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.0.2-r3.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.0.3.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.1.0-r1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.1.1-r3.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.2.0.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.2.1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.2.2.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.2.3.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.3.0.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.3.1-r1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.3.2-r4.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.3.3-r2.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.3.4.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.3.5.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.4.0-r1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.4.1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.4.2.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.4.3-r3.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.4.4-r2.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.4.5.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.4.6-r1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.5.0.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.5.1-r1.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.5.2.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.5.3-r2.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.6.0.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.6.1-r1.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.6.2.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.6.3.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.7.3-r1.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.8.3.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.8.4.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.9.0.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.9.1.ebuild2
-rw-r--r--sys-devel/gcc/gcc-4.9.2.ebuild2
-rw-r--r--sys-devel/gcc/gcc-5.1.0.ebuild2
-rw-r--r--sys-devel/gcc/gcc-5.2.0.ebuild2
-rw-r--r--sys-devel/gcc/gcc-5.3.0.ebuild2
39 files changed, 83 insertions, 83 deletions
diff --git a/sys-devel/gcc/gcc-4.0.0.ebuild b/sys-devel/gcc/gcc-4.0.0.ebuild
index fbf039b..7c72d3e 100644
--- a/sys-devel/gcc/gcc-4.0.0.ebuild
+++ b/sys-devel/gcc/gcc-4.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.0.0.ebuild,v 1.7 2005/07/08 19:07:22 eradicator dead $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.1"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.0.2-r3.ebuild b/sys-devel/gcc/gcc-4.0.2-r3.ebuild
index 97af6ce..da1221a 100644
--- a/sys-devel/gcc/gcc-4.0.2-r3.ebuild
+++ b/sys-devel/gcc/gcc-4.0.2-r3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.0.2-r3.ebuild,v 1.20 2006/12/30 11:33:36 vapier dead $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.6"
PATCH_GCC_VER="4.0.2"
@@ -18,8 +18,8 @@ RDEPEND=""
DEPEND="${RDEPEND}
>=${CATEGORY}/binutils-2.15.94"
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.0.3.ebuild b/sys-devel/gcc/gcc-4.0.3.ebuild
index 20ba64e..343bc57 100644
--- a/sys-devel/gcc/gcc-4.0.3.ebuild
+++ b/sys-devel/gcc/gcc-4.0.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.0.3.ebuild,v 1.15 2008/04/18 18:47:51 vapier dead $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.3"
UCLIBC_VER="1.0"
@@ -16,8 +16,8 @@ RDEPEND=""
DEPEND="${RDEPEND}
>=${CATEGORY}/binutils-2.15.94"
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.1.0-r1.ebuild b/sys-devel/gcc/gcc-4.1.0-r1.ebuild
index 68a7058..e25596a 100644
--- a/sys-devel/gcc/gcc-4.1.0-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.1.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.1.0-r1.ebuild,v 1.17 2009/02/15 23:12:46 vapier dead $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.8"
UCLIBC_VER="1.1"
@@ -15,8 +15,8 @@ RDEPEND=""
DEPEND="${RDEPEND}
>=${CATEGORY}/binutils-2.15.94"
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.1.1-r3.ebuild b/sys-devel/gcc/gcc-4.1.1-r3.ebuild
index 3894a86..cd0810a 100644
--- a/sys-devel/gcc/gcc-4.1.1-r3.ebuild
+++ b/sys-devel/gcc/gcc-4.1.1-r3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.1.1-r3.ebuild,v 1.17 2008/04/18 18:47:51 vapier dead $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.10"
UCLIBC_VER="1.1"
@@ -17,8 +17,8 @@ DEPEND="${RDEPEND}
ppc64? ( >=${CATEGORY}/binutils-2.17 )
>=${CATEGORY}/binutils-2.15.94"
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.2.0.ebuild b/sys-devel/gcc/gcc-4.2.0.ebuild
index d844ac7..dfc00bc 100644
--- a/sys-devel/gcc/gcc-4.2.0.ebuild
+++ b/sys-devel/gcc/gcc-4.2.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.2.0.ebuild,v 1.12 2008/04/18 18:47:51 vapier dead $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.4"
UCLIBC_VER="1.0"
@@ -17,8 +17,8 @@ DEPEND="${RDEPEND}
ppc64? ( >=${CATEGORY}/binutils-2.17 )
>=${CATEGORY}/binutils-2.15.94"
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.2.1.ebuild b/sys-devel/gcc/gcc-4.2.1.ebuild
index 874554a..8dde390 100644
--- a/sys-devel/gcc/gcc-4.2.1.ebuild
+++ b/sys-devel/gcc/gcc-4.2.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.2.1.ebuild,v 1.3 2008/04/18 18:47:51 vapier dead $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.0"
UCLIBC_VER="1.0"
@@ -17,8 +17,8 @@ DEPEND="${RDEPEND}
ppc64? ( >=${CATEGORY}/binutils-2.17 )
>=${CATEGORY}/binutils-2.15.94"
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.2.2.ebuild b/sys-devel/gcc/gcc-4.2.2.ebuild
index 7702802..7c869d1 100644
--- a/sys-devel/gcc/gcc-4.2.2.ebuild
+++ b/sys-devel/gcc/gcc-4.2.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.2.2.ebuild,v 1.5 2008/04/18 18:47:51 vapier dead $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.0"
UCLIBC_VER="1.0"
@@ -17,8 +17,8 @@ DEPEND="${RDEPEND}
ppc64? ( >=${CATEGORY}/binutils-2.17 )
>=${CATEGORY}/binutils-2.15.94"
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.2.3.ebuild b/sys-devel/gcc/gcc-4.2.3.ebuild
index 9c79e25..4f70e7e 100644
--- a/sys-devel/gcc/gcc-4.2.3.ebuild
+++ b/sys-devel/gcc/gcc-4.2.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.2.3.ebuild,v 1.4 2009/02/15 23:12:46 vapier dead $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.0"
UCLIBC_VER="1.0"
@@ -17,8 +17,8 @@ DEPEND="${RDEPEND}
ppc64? ( >=${CATEGORY}/binutils-2.17 )
>=${CATEGORY}/binutils-2.15.94"
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.3.0.ebuild b/sys-devel/gcc/gcc-4.3.0.ebuild
index 473ba3a..c376083 100644
--- a/sys-devel/gcc/gcc-4.3.0.ebuild
+++ b/sys-devel/gcc/gcc-4.3.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.3.0.ebuild,v 1.10 2009/05/09 21:26:13 halcy0n dead $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.2"
UCLIBC_VER="1.0"
@@ -17,8 +17,8 @@ DEPEND="${RDEPEND}
ppc64? ( >=${CATEGORY}/binutils-2.17 )
>=${CATEGORY}/binutils-2.15.94"
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.3.1-r1.ebuild b/sys-devel/gcc/gcc-4.3.1-r1.ebuild
index 5ddf7f6..ee954d2 100644
--- a/sys-devel/gcc/gcc-4.3.1-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.3.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.3.1-r1.ebuild,v 1.4 2009/05/09 21:26:13 halcy0n dead $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.1"
UCLIBC_VER="1.0"
@@ -18,8 +18,8 @@ DEPEND="${RDEPEND}
ppc64? ( >=${CATEGORY}/binutils-2.17 )
>=${CATEGORY}/binutils-2.15.94"
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.3.2-r4.ebuild b/sys-devel/gcc/gcc-4.3.2-r4.ebuild
index 657a294..953740f 100644
--- a/sys-devel/gcc/gcc-4.3.2-r4.ebuild
+++ b/sys-devel/gcc/gcc-4.3.2-r4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.2-r4.ebuild,v 1.9 2010/01/09 12:58:57 ulm Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.8"
UCLIBC_VER="1.0"
@@ -20,8 +20,8 @@ DEPEND="${RDEPEND}
ppc64? ( >=${CATEGORY}/binutils-2.17 )
>=${CATEGORY}/binutils-2.15.94"
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.3.3-r2.ebuild b/sys-devel/gcc/gcc-4.3.3-r2.ebuild
index 4baeb2c..e6201de 100644
--- a/sys-devel/gcc/gcc-4.3.3-r2.ebuild
+++ b/sys-devel/gcc/gcc-4.3.3-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.3-r2.ebuild,v 1.17 2013/04/12 06:47:58 ulm Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.2"
UCLIBC_VER="1.1"
@@ -20,8 +20,8 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.3.4.ebuild b/sys-devel/gcc/gcc-4.3.4.ebuild
index 4c7da6d..c36ddac 100644
--- a/sys-devel/gcc/gcc-4.3.4.ebuild
+++ b/sys-devel/gcc/gcc-4.3.4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.4.ebuild,v 1.24 2013/10/05 04:08:32 dirtyepic Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.4"
UCLIBC_VER="1.0"
@@ -20,8 +20,8 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.3.5.ebuild b/sys-devel/gcc/gcc-4.3.5.ebuild
index d1b29c5..962401d 100644
--- a/sys-devel/gcc/gcc-4.3.5.ebuild
+++ b/sys-devel/gcc/gcc-4.3.5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.5.ebuild,v 1.11 2013/04/12 06:47:58 ulm Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.1"
UCLIBC_VER="1.0"
@@ -20,8 +20,8 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.4.0-r1.ebuild b/sys-devel/gcc/gcc-4.4.0-r1.ebuild
index 6fab87b..4fe310c 100644
--- a/sys-devel/gcc/gcc-4.4.0-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.4.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.4.0-r1.ebuild,v 1.3 2009/08/13 19:40:11 halcy0n dead $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.2"
UCLIBC_VER="1.0"
@@ -20,8 +20,8 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.4.1.ebuild b/sys-devel/gcc/gcc-4.4.1.ebuild
index 79867f1..733aef6 100644
--- a/sys-devel/gcc/gcc-4.4.1.ebuild
+++ b/sys-devel/gcc/gcc-4.4.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.1.ebuild,v 1.13 2010/01/09 12:58:57 ulm Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.0"
UCLIBC_VER="1.1"
@@ -21,8 +21,8 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.4.2.ebuild b/sys-devel/gcc/gcc-4.4.2.ebuild
index 047c219..b79d23e 100644
--- a/sys-devel/gcc/gcc-4.4.2.ebuild
+++ b/sys-devel/gcc/gcc-4.4.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.2.ebuild,v 1.13 2013/04/12 06:47:58 ulm Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.0"
UCLIBC_VER="1.0"
@@ -21,8 +21,8 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.4.3-r3.ebuild b/sys-devel/gcc/gcc-4.4.3-r3.ebuild
index 985c9de..e7a8ba3 100644
--- a/sys-devel/gcc/gcc-4.4.3-r3.ebuild
+++ b/sys-devel/gcc/gcc-4.4.3-r3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.3-r3.ebuild,v 1.16 2013/10/05 04:08:32 dirtyepic Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.4"
UCLIBC_VER="1.0"
@@ -21,8 +21,8 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.4.4-r2.ebuild b/sys-devel/gcc/gcc-4.4.4-r2.ebuild
index 9d27aa5..4b4d318 100644
--- a/sys-devel/gcc/gcc-4.4.4-r2.ebuild
+++ b/sys-devel/gcc/gcc-4.4.4-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.4-r2.ebuild,v 1.19 2013/10/05 04:08:32 dirtyepic Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.4"
UCLIBC_VER="1.0"
@@ -21,8 +21,8 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.4.5.ebuild b/sys-devel/gcc/gcc-4.4.5.ebuild
index ae193cf..dffa47d 100644
--- a/sys-devel/gcc/gcc-4.4.5.ebuild
+++ b/sys-devel/gcc/gcc-4.4.5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.5.ebuild,v 1.17 2013/10/05 04:08:32 dirtyepic Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.3"
UCLIBC_VER="1.0"
@@ -21,8 +21,8 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
diff --git a/sys-devel/gcc/gcc-4.4.6-r1.ebuild b/sys-devel/gcc/gcc-4.4.6-r1.ebuild
index 031ff73..62db020 100644
--- a/sys-devel/gcc/gcc-4.4.6-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.4.6-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.6-r1.ebuild,v 1.13 2013/10/05 04:08:32 dirtyepic Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.0"
UCLIBC_VER="1.0"
@@ -21,8 +21,8 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
diff --git a/sys-devel/gcc/gcc-4.5.0.ebuild b/sys-devel/gcc/gcc-4.5.0.ebuild
index 03aa93f..c293ada 100644
--- a/sys-devel/gcc/gcc-4.5.0.ebuild
+++ b/sys-devel/gcc/gcc-4.5.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.0.ebuild,v 1.12 2010/10/05 15:12:10 zorry Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.5"
UCLIBC_VER="1.0"
@@ -21,8 +21,8 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
- toolchain_src_unpack
+src_prepare() {
+ toolchain_src_prepare
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.5.1-r1.ebuild b/sys-devel/gcc/gcc-4.5.1-r1.ebuild
index da3e6c1..8b5baa1 100644
--- a/sys-devel/gcc/gcc-4.5.1-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.5.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.1-r1.ebuild,v 1.15 2014/10/24 00:23:04 vapier Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.5"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.5.2.ebuild b/sys-devel/gcc/gcc-4.5.2.ebuild
index f21e3f2..625ff8a 100644
--- a/sys-devel/gcc/gcc-4.5.2.ebuild
+++ b/sys-devel/gcc/gcc-4.5.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.2.ebuild,v 1.15 2014/10/24 00:23:04 vapier Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.2"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.5.3-r2.ebuild b/sys-devel/gcc/gcc-4.5.3-r2.ebuild
index 9d23f51..998ffc6 100644
--- a/sys-devel/gcc/gcc-4.5.3-r2.ebuild
+++ b/sys-devel/gcc/gcc-4.5.3-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.3-r2.ebuild,v 1.22 2014/10/24 00:23:04 vapier Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.6"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.6.0.ebuild b/sys-devel/gcc/gcc-4.6.0.ebuild
index 1900fe3..7dc486d 100644
--- a/sys-devel/gcc/gcc-4.6.0.ebuild
+++ b/sys-devel/gcc/gcc-4.6.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.0.ebuild,v 1.18 2014/10/24 00:23:04 vapier Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.3"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.6.1-r1.ebuild b/sys-devel/gcc/gcc-4.6.1-r1.ebuild
index 09354e6..66f3714 100644
--- a/sys-devel/gcc/gcc-4.6.1-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.6.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.1-r1.ebuild,v 1.15 2014/10/24 00:23:04 vapier Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.1"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.6.2.ebuild b/sys-devel/gcc/gcc-4.6.2.ebuild
index 9097efa..d95069c 100644
--- a/sys-devel/gcc/gcc-4.6.2.ebuild
+++ b/sys-devel/gcc/gcc-4.6.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.2.ebuild,v 1.20 2014/10/24 00:23:04 vapier Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.5"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.6.3.ebuild b/sys-devel/gcc/gcc-4.6.3.ebuild
index beb8279..639607e 100644
--- a/sys-devel/gcc/gcc-4.6.3.ebuild
+++ b/sys-devel/gcc/gcc-4.6.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.3.ebuild,v 1.42 2014/10/24 00:23:04 vapier Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.13"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.7.3-r1.ebuild b/sys-devel/gcc/gcc-4.7.3-r1.ebuild
index 9fd7908..0e213e7 100644
--- a/sys-devel/gcc/gcc-4.7.3-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.7.3-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.3-r1.ebuild,v 1.21 2015/03/17 06:41:31 vapier Exp $
-EAPI="2"
+EAPI="5"
PATCH_VER="1.5"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.8.3.ebuild b/sys-devel/gcc/gcc-4.8.3.ebuild
index b583a21..8f862fa 100644
--- a/sys-devel/gcc/gcc-4.8.3.ebuild
+++ b/sys-devel/gcc/gcc-4.8.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
PATCH_VER="1.1"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.8.4.ebuild b/sys-devel/gcc/gcc-4.8.4.ebuild
index 0a74fba..e4d594c 100644
--- a/sys-devel/gcc/gcc-4.8.4.ebuild
+++ b/sys-devel/gcc/gcc-4.8.4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
PATCH_VER="1.8"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.9.0.ebuild b/sys-devel/gcc/gcc-4.9.0.ebuild
index 88b0930..4ba178f 100644
--- a/sys-devel/gcc/gcc-4.9.0.ebuild
+++ b/sys-devel/gcc/gcc-4.9.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
PATCH_VER="1.0"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.9.1.ebuild b/sys-devel/gcc/gcc-4.9.1.ebuild
index 88b0930..4ba178f 100644
--- a/sys-devel/gcc/gcc-4.9.1.ebuild
+++ b/sys-devel/gcc/gcc-4.9.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
PATCH_VER="1.0"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-4.9.2.ebuild b/sys-devel/gcc/gcc-4.9.2.ebuild
index 37861d3..4c809c6 100644
--- a/sys-devel/gcc/gcc-4.9.2.ebuild
+++ b/sys-devel/gcc/gcc-4.9.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
PATCH_VER="1.6"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-5.1.0.ebuild b/sys-devel/gcc/gcc-5.1.0.ebuild
index 10835fc..76982dc 100644
--- a/sys-devel/gcc/gcc-5.1.0.ebuild
+++ b/sys-devel/gcc/gcc-5.1.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI="5"
PATCH_VER="1.2"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-5.2.0.ebuild b/sys-devel/gcc/gcc-5.2.0.ebuild
index cc3fa7b..10fb3af 100644
--- a/sys-devel/gcc/gcc-5.2.0.ebuild
+++ b/sys-devel/gcc/gcc-5.2.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI="5"
PATCH_VER="1.3"
UCLIBC_VER="1.0"
diff --git a/sys-devel/gcc/gcc-5.3.0.ebuild b/sys-devel/gcc/gcc-5.3.0.ebuild
index 53e0918..595be5b 100644
--- a/sys-devel/gcc/gcc-5.3.0.ebuild
+++ b/sys-devel/gcc/gcc-5.3.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI="5"
PATCH_VER="1.1"
UCLIBC_VER="1.0"