summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-4.10.0_pre9999.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.8.4_pre9999.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.9.1_pre9999.ebuild6
-rw-r--r--sys-devel/gcc/metadata.xml1
4 files changed, 3 insertions, 16 deletions
diff --git a/sys-devel/gcc/gcc-4.10.0_pre9999.ebuild b/sys-devel/gcc/gcc-4.10.0_pre9999.ebuild
index 6b82425..1427ade 100644
--- a/sys-devel/gcc/gcc-4.10.0_pre9999.ebuild
+++ b/sys-devel/gcc/gcc-4.10.0_pre9999.ebuild
@@ -11,7 +11,7 @@ inherit toolchain
KEYWORDS=""
SLOT="${GCC_BRANCH_VER}-vcs"
-IUSE="nobootstrap offline"
+IUSE="nobootstrap"
RDEPEND=""
DEPEND="${RDEPEND}
@@ -22,10 +22,6 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- # use the offline USE flag to prevent the ebuild from trying to update from
- # the repo. the current sources will be used instead.
- use offline && EVCS_OFFLINE="yes"
-
toolchain_src_unpack
echo "commit ${EGIT_VERSION}" > "${S}"/gcc/REVISION
diff --git a/sys-devel/gcc/gcc-4.8.4_pre9999.ebuild b/sys-devel/gcc/gcc-4.8.4_pre9999.ebuild
index fa8e0be..b86aae2 100644
--- a/sys-devel/gcc/gcc-4.8.4_pre9999.ebuild
+++ b/sys-devel/gcc/gcc-4.8.4_pre9999.ebuild
@@ -10,7 +10,7 @@ inherit toolchain
KEYWORDS=""
SLOT="${GCC_BRANCH_VER}-vcs"
-IUSE="nobootstrap offline"
+IUSE="nobootstrap"
RDEPEND=""
DEPEND="${RDEPEND}
@@ -21,10 +21,6 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- # use the offline USE flag to prevent the ebuild from trying to update from
- # the repo. the current sources will be used instead.
- use offline && EVCS_OFFLINE="yes"
-
toolchain_src_unpack
echo "commit ${EGIT_VERSION}" > "${S}"/gcc/REVISION
diff --git a/sys-devel/gcc/gcc-4.9.1_pre9999.ebuild b/sys-devel/gcc/gcc-4.9.1_pre9999.ebuild
index fa8e0be..b86aae2 100644
--- a/sys-devel/gcc/gcc-4.9.1_pre9999.ebuild
+++ b/sys-devel/gcc/gcc-4.9.1_pre9999.ebuild
@@ -10,7 +10,7 @@ inherit toolchain
KEYWORDS=""
SLOT="${GCC_BRANCH_VER}-vcs"
-IUSE="nobootstrap offline"
+IUSE="nobootstrap"
RDEPEND=""
DEPEND="${RDEPEND}
@@ -21,10 +21,6 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- # use the offline USE flag to prevent the ebuild from trying to update from
- # the repo. the current sources will be used instead.
- use offline && EVCS_OFFLINE="yes"
-
toolchain_src_unpack
echo "commit ${EGIT_VERSION}" > "${S}"/gcc/REVISION
diff --git a/sys-devel/gcc/metadata.xml b/sys-devel/gcc/metadata.xml
index 71974de..80f6ecd 100644
--- a/sys-devel/gcc/metadata.xml
+++ b/sys-devel/gcc/metadata.xml
@@ -26,7 +26,6 @@
<flag name="objc++">Build support for the Objective C++ language</flag>
<flag name="objc-gc">Build support for the Objective C code language Garbage
Collector</flag>
- <flag name="offline">Build with current checkout</flag>
<flag name="regression-test">Run the testsuite and install the results (requires FEATURES=test)</flag>
<flag name="sanitize">Build support for various sanitizer functions (ASAN/TSAN/etc...)</flag>
<flag name="ssp">Build packages with stack smashing protector on by default</flag>