summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-01-06 16:13:04 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-01-06 16:13:04 +0100
commite088d78ac0870dd02e9ca01794014bda9e371e8f (patch)
tree0daffdd7004f3ec70326e461c6391c6741b6905f
parentAdd patch from floppym (diff)
downloadglibc-patches-e088d78a.tar.gz
glibc-patches-e088d78a.tar.bz2
glibc-patches-e088d78a.zip
Sync with azanella's branch release/2.34/master-bz23960
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--9999/0207-dirent-Deprecate-getdirentries.patch28
-rw-r--r--9999/0208-Build-fix-no-double-__THROW.patch29
2 files changed, 15 insertions, 42 deletions
diff --git a/9999/0207-dirent-Deprecate-getdirentries.patch b/9999/0207-dirent-Deprecate-getdirentries.patch
index 7b00018..f01ab67 100644
--- a/9999/0207-dirent-Deprecate-getdirentries.patch
+++ b/9999/0207-dirent-Deprecate-getdirentries.patch
@@ -1,4 +1,4 @@
-From 8180167096d51c9767888a695e60a542b64813f0 Mon Sep 17 00:00:00 2001
+From 7b990b41ea23c0464c60e6a9f0707adfb46ae587 Mon Sep 17 00:00:00 2001
From: Adhemerval Zanella <adhemerval.zanella@linaro.org>
Date: Fri, 17 Apr 2020 09:59:51 -0300
Subject: [PATCH 7/7] dirent: Deprecate getdirentries
@@ -17,16 +17,16 @@ The interface has some issues:
The idea is to eventually move the symbols to compat ones.
---
- NEWS | 5 +++++
+ NEWS | 6 ++++++
dirent/dirent.h | 14 ++++++++++----
- sysdeps/unix/sysv/linux/Makefile | 3 +++
- 3 files changed, 18 insertions(+), 4 deletions(-)
+ sysdeps/unix/sysv/linux/Makefile | 4 ++++
+ 3 files changed, 20 insertions(+), 4 deletions(-)
diff --git a/NEWS b/NEWS
-index d9b344027b..a18a1d7a8c 100644
+index d9b344027b..45e51ae810 100644
--- a/NEWS
+++ b/NEWS
-@@ -7,6 +7,11 @@ using `glibc' in the "product" field.
+@@ -7,6 +7,12 @@ using `glibc' in the "product" field.
Version 2.34.1
@@ -35,11 +35,12 @@ index d9b344027b..a18a1d7a8c 100644
+* The function getdirentries is now deprecated, applications should use
+ either getdents64, readdir64 or readdir.
+
++
The following bugs are resolved with this release:
[12889] nptl: Fix race between pthread_kill and thread exit
diff --git a/dirent/dirent.h b/dirent/dirent.h
-index 1d1fab7e55..8ad5fbf430 100644
+index 1d1fab7e55..eed030b379 100644
--- a/dirent/dirent.h
+++ b/dirent/dirent.h
@@ -348,29 +348,35 @@ extern int alphasort64 (const struct dirent64 **__e1,
@@ -64,7 +65,7 @@ index 1d1fab7e55..8ad5fbf430 100644
__off64_t *__restrict __basep),
- getdirentries64) __nonnull ((2, 4));
+ getdirentries64)
-+ __THROW __nonnull ((2, 4))
++ __nonnull ((2, 4))
+ __attribute_deprecated_msg__ ("Use getdents64 instead");
# else
# define getdirentries getdirentries64
@@ -83,19 +84,20 @@ index 1d1fab7e55..8ad5fbf430 100644
#endif /* Use misc. */
diff --git a/sysdeps/unix/sysv/linux/Makefile b/sysdeps/unix/sysv/linux/Makefile
-index 76ad06361c..65ec7529f6 100644
+index 76ad06361c..2bfb6e254b 100644
--- a/sysdeps/unix/sysv/linux/Makefile
+++ b/sysdeps/unix/sysv/linux/Makefile
-@@ -313,6 +313,9 @@ tests += tst-getdents64
- # The tested readdir64 symbol was replaced in glibc 2.2.
+@@ -314,6 +314,10 @@ tests += tst-getdents64
ifeq ($(have-GLIBC_2.1.3)$(build-shared),yesyes)
tests += tst-readdir64-compat
+ endif
+
+# Avoid the warning for the weak_alias for _DIRENT_MATCHES_DIRENT64
-+CFLAGS-getdirentries64.c = -Wno-deprecated-declarations
- endif
++CFLAGS-getdirentries64.o = -Wno-deprecated-declarations
++CFLAGS-getdirentries64.os = -Wno-deprecated-declarations
endif # $(subdir) == dirent
+ ifeq ($(subdir),nis)
--
2.32.0
diff --git a/9999/0208-Build-fix-no-double-__THROW.patch b/9999/0208-Build-fix-no-double-__THROW.patch
deleted file mode 100644
index 56c3afa..0000000
--- a/9999/0208-Build-fix-no-double-__THROW.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From fc24fb7c47dbe4e279a3853ee6eff6565348ca47 Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Wed, 5 Jan 2022 22:11:49 +0100
-Subject: [PATCH] Build fix (no double __THROW)
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
----
- dirent/dirent.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/dirent/dirent.h b/dirent/dirent.h
-index 8ad5fbf430..eed030b379 100644
---- a/dirent/dirent.h
-+++ b/dirent/dirent.h
-@@ -363,7 +363,7 @@ extern __ssize_t __REDIRECT_NTH (getdirentries,
- size_t __nbytes,
- __off64_t *__restrict __basep),
- getdirentries64)
-- __THROW __nonnull ((2, 4))
-+ __nonnull ((2, 4))
- __attribute_deprecated_msg__ ("Use getdents64 instead");
- # else
- # define getdirentries getdirentries64
---
-2.32.0
-