summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-10 22:05:40 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-10 22:05:40 +0100
commit032e9bcfdf46b098792c0777d63c53d720748ae5 (patch)
tree432369119a0aee110342bd05e5521492dbf05b90
parentREADME.Gentoo.patches: modernise a bit (diff)
downloadlinux-headers-patches-032e9bcf.tar.gz
linux-headers-patches-032e9bcf.tar.bz2
linux-headers-patches-032e9bcf.zip
5.16: new patchset, clone of 5.15
* 5.16/00_all_0001-unifdef-drop-unused-errno.h-include.patch * 5.16/00_all_0002-x86-do-not-build-relocs-tool-when-installing-headers.patch * 5.16/00_all_0003-uapi-fix-System-V-buf-header-includes.patch Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--5.16/00_all_0001-unifdef-drop-unused-errno.h-include.patch32
-rw-r--r--5.16/00_all_0002-x86-do-not-build-relocs-tool-when-installing-headers.patch33
-rw-r--r--5.16/00_all_0003-uapi-fix-System-V-buf-header-includes.patch28
3 files changed, 93 insertions, 0 deletions
diff --git a/5.16/00_all_0001-unifdef-drop-unused-errno.h-include.patch b/5.16/00_all_0001-unifdef-drop-unused-errno.h-include.patch
new file mode 100644
index 0000000..617eb9a
--- /dev/null
+++ b/5.16/00_all_0001-unifdef-drop-unused-errno.h-include.patch
@@ -0,0 +1,32 @@
+From c4d1a109c5c0b1bd27d2b5448a1306a2f6005339 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 6 Dec 2011 17:22:42 -0500
+Subject: [PATCH] unifdef: drop unused errno.h include
+
+This is the only header on my system that ends up requiring kernel
+headers, so if the kernel headers aren't available, we end up being
+unable to install kernel headers :).
+
+Since this file doesn't actually use anything from errno.h, drop
+the include so it at least makes us a bit more robust on glibc.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ scripts/unifdef.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/scripts/unifdef.c b/scripts/unifdef.c
+index 7493c0ee51cc..c5dfae538b08 100644
+--- a/scripts/unifdef.c
++++ b/scripts/unifdef.c
+@@ -48,7 +48,6 @@
+
+ #include <ctype.h>
+ #include <err.h>
+-#include <errno.h>
+ #include <stdarg.h>
+ #include <stdbool.h>
+ #include <stdio.h>
+--
+2.16.1
+
diff --git a/5.16/00_all_0002-x86-do-not-build-relocs-tool-when-installing-headers.patch b/5.16/00_all_0002-x86-do-not-build-relocs-tool-when-installing-headers.patch
new file mode 100644
index 0000000..a82c98e
--- /dev/null
+++ b/5.16/00_all_0002-x86-do-not-build-relocs-tool-when-installing-headers.patch
@@ -0,0 +1,33 @@
+From 57875de37c5375ea95e1e949ec7c741d0038d3a1 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 15 Nov 2014 03:37:38 -0500
+Subject: [PATCH] x86: do not build relocs tool when installing headers
+
+This isn't needed to install headers, so don't bother building it.
+Otherwise we run into a chicken/egg issue where we need the kernel
+headers in order to install the kernel headers. It's also a waste
+of time.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ arch/x86/Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/arch/x86/Makefile b/arch/x86/Makefile
+index 60135cbd905c..9b15b2daa77f 100644
+--- a/arch/x86/Makefile
++++ b/arch/x86/Makefile
+@@ -221,8 +221,10 @@
+ endif
+
+
++ifneq ($(filter-out headers_install,$(MAKECMDGOALS)),)
+ archscripts: scripts_basic
+ $(Q)$(MAKE) $(build)=arch/x86/tools relocs
++endif
+
+ ###
+ # Syscall table generation
+--
+2.16.1
+
diff --git a/5.16/00_all_0003-uapi-fix-System-V-buf-header-includes.patch b/5.16/00_all_0003-uapi-fix-System-V-buf-header-includes.patch
new file mode 100644
index 0000000..987a98d
--- /dev/null
+++ b/5.16/00_all_0003-uapi-fix-System-V-buf-header-includes.patch
@@ -0,0 +1,28 @@
+From beac664726b0b5b5c833aaf6576ca583534406ba Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 2 Nov 2015 13:30:12 -0500
+Subject: [PATCH] uapi: fix System V buf header includes
+
+These headers rely on kernel types but don't include the other headers
+that define them. So when you try to include them directly, you often
+hit build failures due to unknown types.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+
+diff --git a/include/uapi/asm-generic/shmbuf.h b/include/uapi/asm-generic/shmbuf.h
+index 2b6c3bb97f97..a0171147d796 100644
+--- a/include/uapi/asm-generic/shmbuf.h
++++ b/include/uapi/asm-generic/shmbuf.h
+@@ -2,7 +2,9 @@
+ #ifndef __ASM_GENERIC_SHMBUF_H
+ #define __ASM_GENERIC_SHMBUF_H
+
++
+ #include <asm/bitsperlong.h>
++#include <asm/ipcbuf.h>
+
+ /*
+ * The shmid64_ds structure for x86 architecture.
+--
+2.16.1
+