aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Magorsch <max@magorsch.de>2020-01-24 16:38:41 +0100
committerMax Magorsch <max@magorsch.de>2020-01-24 16:38:41 +0100
commit4b23f73dd107c94727271c844a1a680258155836 (patch)
treee8d69324a5d40be2a5c23d42599bc76247ff6988
parentDisplay the longdescription correctly on pypi (diff)
downloadtyrian-sphinx-theme-4b23f73dd107c94727271c844a1a680258155836.tar.gz
tyrian-sphinx-theme-4b23f73dd107c94727271c844a1a680258155836.tar.bz2
tyrian-sphinx-theme-4b23f73dd107c94727271c844a1a680258155836.zip
Add a github workflow for publishing to pypi
The package will be automatically published to pypi using a github action. Signed-off-by: Max Magorsch <max@magorsch.de>
-rw-r--r--.github/workflows/pythonpublish.yml26
1 files changed, 26 insertions, 0 deletions
diff --git a/.github/workflows/pythonpublish.yml b/.github/workflows/pythonpublish.yml
new file mode 100644
index 0000000..21f2f01
--- /dev/null
+++ b/.github/workflows/pythonpublish.yml
@@ -0,0 +1,26 @@
+name: Upload Python Package
+
+on:
+ release:
+ types: [created]
+
+jobs:
+ deploy:
+ runs-on: ubuntu-latest
+ steps:
+ - uses: actions/checkout@v1
+ - name: Set up Python
+ uses: actions/setup-python@v1
+ with:
+ python-version: '3.x'
+ - name: Install dependencies
+ run: |
+ python -m pip install --upgrade pip
+ pip install setuptools wheel twine
+ - name: Build and publish
+ env:
+ TWINE_USERNAME: ${{ secrets.PYPI_USERNAME }}
+ TWINE_PASSWORD: ${{ secrets.PYPI_PASSWORD }}
+ run: |
+ python setup.py sdist bdist_wheel
+ twine upload dist/*