summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2013-01-31 19:18:56 +0100
committerSven Eden <sven.eden@gmx.de>2013-01-31 19:18:56 +0100
commite4944be76a346f34b679d5008827864b7b04df2b (patch)
treee47de26ce6740c44a621f931c1da9cf4d8bacb24
parentChanged names for the renamed files in Makefile.am (ufed-curses-debug.h, ufed... (diff)
downloadufed-e4944be76a346f34b679d5008827864b7b04df2b.tar.gz
ufed-e4944be76a346f34b679d5008827864b7b04df2b.tar.bz2
ufed-e4944be76a346f34b679d5008827864b7b04df2b.zip
Added two missing checks
-rw-r--r--config.h.in36
-rw-r--r--configure.ac3
2 files changed, 39 insertions, 0 deletions
diff --git a/config.h.in b/config.h.in
index 98d0c13..0916a33 100644
--- a/config.h.in
+++ b/config.h.in
@@ -1,5 +1,35 @@
/* config.h.in. Generated from configure.ac by autoheader. */
+/* Define to 1 if you have the <inttypes.h> header file. */
+#undef HAVE_INTTYPES_H
+
+/* Define to 1 if you have the <memory.h> header file. */
+#undef HAVE_MEMORY_H
+
+/* Define to 1 if you have the <stdint.h> header file. */
+#undef HAVE_STDINT_H
+
+/* Define to 1 if you have the <stdlib.h> header file. */
+#undef HAVE_STDLIB_H
+
+/* Define to 1 if you have the <strings.h> header file. */
+#undef HAVE_STRINGS_H
+
+/* Define to 1 if you have the <string.h> header file. */
+#undef HAVE_STRING_H
+
+/* Define to 1 if you have the <sys/stat.h> header file. */
+#undef HAVE_SYS_STAT_H
+
+/* Define to 1 if you have the <sys/types.h> header file. */
+#undef HAVE_SYS_TYPES_H
+
+/* Define to 1 if you have the <unistd.h> header file. */
+#undef HAVE_UNISTD_H
+
+/* Define to 1 if the system has the type `_Bool'. */
+#undef HAVE__BOOL
+
/* Name of package */
#undef PACKAGE
@@ -21,6 +51,9 @@
/* Define to the version of this package. */
#undef PACKAGE_VERSION
+/* Define to 1 if you have the ANSI C header files. */
+#undef STDC_HEADERS
+
/* Version number of package */
#undef VERSION
@@ -29,3 +62,6 @@
#ifndef __cplusplus
#undef inline
#endif
+
+/* Define to `unsigned int' if <sys/types.h> does not define. */
+#undef size_t
diff --git a/configure.ac b/configure.ac
index 50c54ca..1f47b68 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,9 @@ else
fi
CFLAGS="${CFLAGS} -Wmissing-prototypes -Wstrict-prototypes"
+AC_TYPE_SIZE_T
+AC_CHECK_HEADER_STDBOOL
+
AC_ARG_WITH([curses],
[AS_HELP_STRING([--with-curses], [override default curses library (ncursesw ncurses curses)])],
[curses=$withval],