summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-07-12 15:30:29 +0200
committerThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-07-13 16:15:57 +0200
commitaef97da3e143463eb88bbc2c04617a858bd2cca5 (patch)
tree11679acd2b40e5cf5669bcd799625e5899b8dec0
downloadvim-patches-aef97da3e143463eb88bbc2c04617a858bd2cca5.tar.gz
vim-patches-aef97da3e143463eb88bbc2c04617a858bd2cca5.tar.bz2
vim-patches-aef97da3e143463eb88bbc2c04617a858bd2cca5.zip
import patchset for vim-8.2.0360
Link: https://dev.gentoo.org/~zlogene/distfiles/app-editors/vim/vim-8.2.0360-gentoo-patches.tar.xz Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz>
-rw-r--r--001_all_vim-6.3-xorg-75816.patch20
-rw-r--r--002_all_vim-7.3-apache-83565.patch12
-rw-r--r--003_all_vim-7.0-automake-substitutions-93378.patch39
-rw-r--r--004_all_vim-7.0-grub-splash-96155.patch11
-rw-r--r--005_all_vim_7.1-ada-default-compiler.patch17
-rw-r--r--006-vim-8.0.0617-crosscompile.patch22
-rw-r--r--007-vim-8.2.0210-python3-shared-lib.patch16
7 files changed, 137 insertions, 0 deletions
diff --git a/001_all_vim-6.3-xorg-75816.patch b/001_all_vim-6.3-xorg-75816.patch
new file mode 100644
index 0000000..568b47a
--- /dev/null
+++ b/001_all_vim-6.3-xorg-75816.patch
@@ -0,0 +1,20 @@
+# Better support for xorg-x11 when syntax highlighting. Gentoo bug 75816.
+
+--- a/runtime/syntax/xf86conf.vim
++++ b/runtime/syntax/xf86conf.vim
+@@ -68,6 +68,7 @@
+ syn region xf86confSectionMonitor matchgroup=xf86confSectionDelim start="^\s*Section\s\+\"Monitor\"" end="^\s*EndSection\>" skip="#.*$\|\"[^\"]*\"" contains=xf86confSubsectionMode,xf86confModeLine,xf86confComment,xf86confOption,xf86confKeyword
+ syn region xf86confSectionModes matchgroup=xf86confSectionDelim start="^\s*Section\s\+\"Modes\"" end="^\s*EndSection\>" skip="#.*$\|\"[^\"]*\"" contains=xf86confSubsectionMode,xf86confModeLine,xf86confComment
+ syn region xf86confSectionScreen matchgroup=xf86confSectionDelim start="^\s*Section\s\+\"Screen\"" end="^\s*EndSection\>" skip="#.*$\|\"[^\"]*\"" contains=xf86confSubsectionDisplay,xf86confComment,xf86confOption,xf86confKeyword
++ syn region xf86confSectionExtensions matchgroup=xf86confSectionDelim start="^\s*Section\s\+\"Extensions\"" end="^\s*EndSection\>" skip="#.*$\|\"[^\"]*\"" contains=xf86confComment,xf86confOption,xf86confKeyword
+ syn region xf86confSubSectionAny matchgroup=xf86confSectionDelim start="^\s*SubSection\s\+\"[^\"]\+\"" end="^\s*EndSubSection\>" skip="#.*$\|\"[^\"]*\"" contains=xf86confComment,xf86confOption,xf86confKeyword,@xf86confSectionErrors
+ syn region xf86confSubSectionMode matchgroup=xf86confSectionDelim start="^\s*Mode\s\+\"[^\"]\+\"" end="^\s*EndMode\>" skip="#.*$\|\"[^\"]*\"" contains=xf86confComment,xf86confKeyword,@xf86confSectionErrors
+ syn region xf86confSubSectionDisplay matchgroup=xf86confSectionDelim start="^\s*SubSection\s\+\"Display\"" end="^\s*EndSubSection\>" skip="#.*$\|\"[^\"]*\"" contains=xf86confComment,xf86confOption,xf86confKeyword,@xf86confSectionErrors
+@@ -174,6 +175,7 @@
+ endif
+ syn sync match xf86confSyncSectionMonitor groupthere xf86confSectionMonitor "^\s*Section\s\+\"Monitor\""
+ syn sync match xf86confSyncSectionScreen groupthere xf86confSectionScreen "^\s*Section\s\+\"Screen\""
++syn sync match xf86confSyncSectionExtensions groupthere xf86confSectionExtensions "^\s*Section\s\+\"Extensions\""
+ syn sync match xf86confSyncEndSection groupthere NONE "^\s*End_*Section\s*$"
+
+ " Define the default highlighting
diff --git a/002_all_vim-7.3-apache-83565.patch b/002_all_vim-7.3-apache-83565.patch
new file mode 100644
index 0000000..b68dcfa
--- /dev/null
+++ b/002_all_vim-7.3-apache-83565.patch
@@ -0,0 +1,12 @@
+--- a/runtime/filetype.vim
++++ b/runtime/filetype.vim
+@@ -113,6 +113,9 @@
+ au BufNewFile,BufRead .htaccess,/etc/httpd/*.conf setf apache
+ au BufNewFile,BufRead httpd.conf*,srm.conf*,access.conf*,apache.conf*,apache2.conf*,/etc/apache2/*.conf*,/etc/httpd/conf.d/*.conf* call s:StarSetf('apache')
+
++" Gentoo apache config file locations (Gentoo bug #83565)
++au BufNewFile,BufRead /etc/apache2/{modules,vhosts}.d/*.conf call s:StarSetf('apache')
++
+ " XA65 MOS6510 cross assembler
+ au BufNewFile,BufRead *.a65 setf a65
+
diff --git a/003_all_vim-7.0-automake-substitutions-93378.patch b/003_all_vim-7.0-automake-substitutions-93378.patch
new file mode 100644
index 0000000..ae73eb8
--- /dev/null
+++ b/003_all_vim-7.0-automake-substitutions-93378.patch
@@ -0,0 +1,39 @@
+---
+ runtime/syntax/automake.vim | 3 +++
+ runtime/syntax/make.vim | 6 ++----
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/runtime/syntax/automake.vim b/runtime/syntax/automake.vim
+index 8a7db7c..cb2b82f 100644
+--- a/runtime/syntax/automake.vim
++++ b/runtime/syntax/automake.vim
+@@ -53,6 +53,9 @@ syn region automakeMakeSString start=+'+ skip=+\\'+ end=+'+ contains=makeIde
+ syn region automakeMakeBString start=+`+ skip=+\\`+ end=+`+ contains=makeIdent,makeSString,makeDString,makeNextLine,automakeSubstitution
+
+ " Define the default highlighting.
++
++syn cluster makeCommandsContains add=autoMakeSubst,automakeMakeError,automakeBadSubst
++
+ " Only when an item doesn't have highlighting yet
+
+ hi def link automakePrimary Statement
+diff --git a/runtime/syntax/make.vim b/runtime/syntax/make.vim
+index 2a64dcd..7325db1 100644
+--- a/runtime/syntax/make.vim
++++ b/runtime/syntax/make.vim
+@@ -62,10 +62,8 @@ syn match makeSpecTarget "^\.\(SUFFIXES\|PHONY\|DEFAULT\|PRECIOUS\|IGNORE\|SILEN
+ \ skipnl nextgroup=makeCommands,makeCommandError
+
+ syn match makeCommandError "^\s\+\S.*" contained
+-syn region makeCommands contained start=";"hs=s+1 start="^\t"
+- \ end="^[^\t#]"me=e-1,re=e-1 end="^$"
+- \ contains=makeCmdNextLine,makeSpecial,makeComment,makeIdent,makePreCondit,makeDefine,makeDString,makeSString
+- \ nextgroup=makeCommandError
++syn region makeCommands start=";"hs=s+1 start="^\t" end="^[^\t#]"me=e-1,re=e-1 end="^$" contained contains=@makeCommandsContains nextgroup=makeCommandError
++syn cluster makeCommandsContains add=makeCmdNextLine,makeSpecial,makeComment,makeIdent,makePreCondit,makeDefine,makeDString,makeSString
+ syn match makeCmdNextLine "\\\n."he=e-1 contained
+
+ " some directives
+--
+2.24.1
+
diff --git a/004_all_vim-7.0-grub-splash-96155.patch b/004_all_vim-7.0-grub-splash-96155.patch
new file mode 100644
index 0000000..b02fa42
--- /dev/null
+++ b/004_all_vim-7.0-grub-splash-96155.patch
@@ -0,0 +1,11 @@
+--- a/runtime/syntax/grub.vim
++++ b/runtime/syntax/grub.vim
+@@ -27,7 +27,7 @@
+
+ syn cluster grubCommands contains=grubCommand,grubTitleCommand
+
+-syn keyword grubCommand contained default fallback hiddenmenu timeout
++syn keyword grubCommand contained default fallback hiddenmenu timeout splashimage
+
+ syn keyword grubTitleCommand contained title nextgroup=grubTitle skipwhite
+
diff --git a/005_all_vim_7.1-ada-default-compiler.patch b/005_all_vim_7.1-ada-default-compiler.patch
new file mode 100644
index 0000000..3a3e78b
--- /dev/null
+++ b/005_all_vim_7.1-ada-default-compiler.patch
@@ -0,0 +1,17 @@
+--- a/runtime/ftplugin/ada.vim
++++ b/runtime/ftplugin/ada.vim
+@@ -126,9 +126,11 @@
+ endif
+ endif
+
+-if ! exists("current_compiler") ||
+- \ current_compiler != g:ada_default_compiler
+- execute "compiler " . g:ada_default_compiler
++if exists("g:ada_default_compiler")
++ if ! exists("current_compiler") ||
++ \ current_compiler != g:ada_default_compiler
++ execute "compiler " . g:ada_default_compiler
++ endif
+ endif
+
+ " Section: Folding {{{1
diff --git a/006-vim-8.0.0617-crosscompile.patch b/006-vim-8.0.0617-crosscompile.patch
new file mode 100644
index 0000000..8328171
--- /dev/null
+++ b/006-vim-8.0.0617-crosscompile.patch
@@ -0,0 +1,22 @@
+Skip failing configure checks during cross-compile builds (bug #473372).
+
+--- vim-8.0.0617/src/configure.ac
++++ vim-8.0.0617/src/configure.ac
+@@ -3303,7 +3303,7 @@
+ # include <stddef.h>
+ #endif
+ main() {char *s; s=(char *)tgoto("%p1%d", 0, 1); exit(0); }],
+- res="OK", res="FAIL", res="FAIL")
++ res="OK", res="FAIL", res="OK")
+ if test "$res" = "OK"; then
+ break
+ fi
+@@ -3373,7 +3373,7 @@
+ ],[
+ vim_cv_tgent=non-zero
+ ],[
+- AC_MSG_ERROR(failed to compile test program.)
++ vim_cv_tgent=zero
+ ])
+ ])
+
diff --git a/007-vim-8.2.0210-python3-shared-lib.patch b/007-vim-8.2.0210-python3-shared-lib.patch
new file mode 100644
index 0000000..84ec559
--- /dev/null
+++ b/007-vim-8.2.0210-python3-shared-lib.patch
@@ -0,0 +1,16 @@
+Drop python3 config dir from library search list to avoid linking against the
+static library that may exist there (bug #669306).
+
+diff --git a/src/configure.ac b/src/configure.ac
+index a098da82e..7aedd7bee 100644
+--- a/src/configure.ac
++++ b/src/configure.ac
+@@ -1496,7 +1496,7 @@ eof
+ dnl -- delete the lines from make about Entering/Leaving directory
+ eval "`cd ${PYTHON3_CONFDIR} && make -f "${tmp_mkf}" __ | sed '/ directory /d'`"
+ rm -f -- "${tmp_mkf}"
+- vi_cv_path_python3_plibs="-L${PYTHON3_CONFDIR} -lpython${vi_cv_var_python3_version}${vi_cv_var_python3_abiflags}"
++ vi_cv_path_python3_plibs="-lpython${vi_cv_var_python3_version}${vi_cv_var_python3_abiflags}"
+ vi_cv_path_python3_plibs="${vi_cv_path_python3_plibs} ${python3_BASEMODLIBS} ${python3_LIBS} ${python3_SYSLIBS}"
+ dnl remove -ltermcap, it can conflict with an earlier -lncurses
+ vi_cv_path_python3_plibs=`echo $vi_cv_path_python3_plibs | sed s/-ltermcap//`