summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/linphone/linphone-1.5.1.ebuild')
-rw-r--r--net-misc/linphone/linphone-1.5.1.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/net-misc/linphone/linphone-1.5.1.ebuild b/net-misc/linphone/linphone-1.5.1.ebuild
index 412a33e..d844a03 100644
--- a/net-misc/linphone/linphone-1.5.1.ebuild
+++ b/net-misc/linphone/linphone-1.5.1.ebuild
@@ -2,6 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/linphone-1.3.5.ebuild,v 1.9 2006/07/01 11:08:57 pylon Exp $
+WANT_AUTOCONF="2.5"
+WANT_AUTOMAKE="1.9"
+
inherit eutils autotools
MY_DPV="${PV%.*}.x"
@@ -33,6 +36,14 @@ RDEPEND="dev-libs/glib
portaudio? ( >=media-libs/portaudio-19_pre )"
DEPEND="${RDEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch
+ ./autogen.sh
+}
+
src_compile() {
local withgnome myconf=""