summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/tests/Makefile.am')
-rw-r--r--src/core/tests/Makefile.am20
1 files changed, 14 insertions, 6 deletions
diff --git a/src/core/tests/Makefile.am b/src/core/tests/Makefile.am
index 2fb4ee7..2f2d305 100644
--- a/src/core/tests/Makefile.am
+++ b/src/core/tests/Makefile.am
@@ -1,6 +1,10 @@
-INCLUDES = -I$(top_srcdir)
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/include
-LIBRCSCRIPTS = $(top_builddir)/librcscripts/librcscripts.la
+LIBRCUTIL = $(top_builddir)/librcutil/librcutil.la
+LIBRCCORE = $(top_builddir)/librccore/librccore.la
TESTS = \
test-dynbuf \
@@ -9,16 +13,20 @@ TESTS = \
noinst_PROGRAMS = \
test-runlevels \
+ test-services \
$(TESTS)
-test_dynbuf_LDADD = $(LIBRCSCRIPTS)
+test_dynbuf_LDADD = $(LIBRCUTIL)
test_dynbuf_SOURCES = test-dynbuf.c
-test_mmap_LDADD = $(LIBRCSCRIPTS)
+test_mmap_LDADD = $(LIBRCUTIL)
test_mmap_SOURCES = test-mmap.c
-test_regex_LDADD = $(LIBRCSCRIPTS)
+test_regex_LDADD = $(LIBRCUTIL)
test_regex_SOURCES = test-regex.c
-test_runlevels_LDADD = $(LIBRCSCRIPTS)
+test_runlevels_LDADD = $(LIBRCCORE)
test_runlevels_SOURCES = test-runlevels.c
+
+test_services_LDADD = $(LIBRCCORE)
+test_services_SOURCES = test-services.c