summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'openvz-sources/026.007/0001_linux-2.6.0-nonintconfig.patch')
-rw-r--r--openvz-sources/026.007/0001_linux-2.6.0-nonintconfig.patch99
1 files changed, 0 insertions, 99 deletions
diff --git a/openvz-sources/026.007/0001_linux-2.6.0-nonintconfig.patch b/openvz-sources/026.007/0001_linux-2.6.0-nonintconfig.patch
deleted file mode 100644
index a7fe97d..0000000
--- a/openvz-sources/026.007/0001_linux-2.6.0-nonintconfig.patch
+++ /dev/null
@@ -1,99 +0,0 @@
---- ./scripts/kconfig/Makefile.nonint 2006-01-03 06:21:10.000000000 +0300
-+++ ./scripts/kconfig/Makefile 2006-01-16 16:59:19.000000000 +0300
-@@ -42,6 +42,10 @@ update-po-config: $(obj)/kxgettext
- $(Q)rm -f arch/um/Kconfig_arch
- $(Q)rm -f scripts/kconfig/linux_*.pot scripts/kconfig/config.pot
-
-+nonint_oldconfig: scripts/kconfig/conf
-+ ./scripts/kconfig/conf -b arch/$(ARCH)/Kconfig
-+
-+
- .PHONY: randconfig allyesconfig allnoconfig allmodconfig defconfig
-
- randconfig: $(obj)/conf
---- ./scripts/kconfig/conf.c.nonint 2006-01-03 06:21:10.000000000 +0300
-+++ ./scripts/kconfig/conf.c 2006-01-16 16:10:30.000000000 +0300
-@@ -20,6 +20,7 @@ enum {
- ask_all,
- ask_new,
- ask_silent,
-+ dont_ask,
- set_default,
- set_yes,
- set_mod,
-@@ -36,6 +37,8 @@ static struct menu *rootEntry;
-
- static char nohelp_text[] = N_("Sorry, no help available for this option yet.\n");
-
-+static int return_value = 0;
-+
- static void strip(char *str)
- {
- char *p = str;
-@@ -102,6 +105,12 @@ static void conf_askvalue(struct symbol
- fflush(stdout);
- fgets(line, 128, stdin);
- return;
-+ case dont_ask:
-+ if (!sym_has_value(sym)) {
-+ fprintf(stderr,"CONFIG_%s\n",sym->name);
-+ return_value++;
-+ }
-+ return;
- case set_default:
- printf("%s\n", def);
- return;
-@@ -346,6 +355,10 @@ static int conf_choice(struct menu *menu
- printf("?");
- printf("]: ");
- switch (input_mode) {
-+ case dont_ask:
-+ cnt = def;
-+ printf("%d\n", cnt);
-+ break;
- case ask_new:
- case ask_silent:
- if (!is_new) {
-@@ -482,7 +495,10 @@ static void check_conf(struct menu *menu
- if (!conf_cnt++)
- printf(_("*\n* Restart config...\n*\n"));
- rootEntry = menu_get_parent_menu(menu);
-- conf(rootEntry);
-+ if (input_mode == dont_ask)
-+ fprintf(stderr,"CONFIG_%s\n",sym->name);
-+ else
-+ conf(rootEntry);
- }
- }
-
-@@ -501,6 +517,9 @@ int main(int ac, char **av)
- case 'o':
- input_mode = ask_new;
- break;
-+ case 'b':
-+ input_mode = dont_ask;
-+ break;
- case 's':
- input_mode = ask_silent;
- valid_stdin = isatty(0) && isatty(1) && isatty(2);
-@@ -565,6 +584,7 @@ int main(int ac, char **av)
- }
- case ask_all:
- case ask_new:
-+ case dont_ask:
- conf_read(NULL);
- break;
- case set_no:
-@@ -603,10 +623,10 @@ int main(int ac, char **av)
- do {
- conf_cnt = 0;
- check_conf(&rootmenu);
-- } while (conf_cnt);
-+ } while ((conf_cnt) && (input_mode != dont_ask));
- if (conf_write(NULL)) {
- fprintf(stderr, _("\n*** Error during writing of the kernel configuration.\n\n"));
- return 1;
- }
-- return 0;
-+ return return_value;
- }