summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcpuid <cpuid@localhost>2009-02-21 05:01:15 +0000
committercpuid <cpuid@localhost>2009-02-21 05:01:15 +0000
commit4e98f96966f9b6c005a81554747c0eeb4d8f6f1f (patch)
treedffec0292bd33c04ac13d3b6df2b609b6be68845 /mail-client/roundcube/roundcube-0.1.ebuild
parentremoving some old cruft (old pre-final 1.2 builds) (diff)
downloadwebapps-experimental-4e98f96966f9b6c005a81554747c0eeb4d8f6f1f.tar.gz
webapps-experimental-4e98f96966f9b6c005a81554747c0eeb4d8f6f1f.tar.bz2
webapps-experimental-4e98f96966f9b6c005a81554747c0eeb4d8f6f1f.zip
0.2 is in the mainline tree now, no need to be here :)
svn path=/experimental/; revision=854
Diffstat (limited to 'mail-client/roundcube/roundcube-0.1.ebuild')
-rw-r--r--mail-client/roundcube/roundcube-0.1.ebuild84
1 files changed, 0 insertions, 84 deletions
diff --git a/mail-client/roundcube/roundcube-0.1.ebuild b/mail-client/roundcube/roundcube-0.1.ebuild
deleted file mode 100644
index eed85f4..0000000
--- a/mail-client/roundcube/roundcube-0.1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils webapp depend.php depend.apache
-
-MY_PN="${PN}mail"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A browser-based multilingual IMAP client using AJAX"
-HOMEPAGE="http://www.roundcube.net"
-SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
-
-# roundcube is GPL-licensed, the rest of the licenses here are
-# for bundled PEAR components, googiespell and utf8.class.php
-LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
-KEYWORDS="~amd64 ~x86"
-IUSE="ldap mysql postgres sqlite ssl spell"
-
-RDEPEND="dev-php/PEAR-PEAR"
-need_httpd_cgi
-need_php_httpd
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- local flags="crypt iconv imap pcre session unicode"
- use ldap && flags="${flags} ldap"
- use ssl && flags="${flags} ssl"
- use spell && flags="${flags} curl ssl"
-
- # check for required PHP features
- if ! use mysql && ! use postgres && ! use sqlite ; then
- local dbflags="mysql mysqli postgres sqlite"
- if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
- ! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} ; then
- die "Re-install ${PHP_PKG} with ${flags} and at least one of ${dbflags} in USE."
- fi
- else
- for db in postgres sqlite ; do
- use ${db} && flags="${flags} ${db}"
- done
- if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
- ( use mysql && ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ) ; then
- local diemsg="Re-install ${PHP_PKG} with ${flags}"
- use mysql && diemsg="${diemsg} and at least one of mysql mysqli"
- die "${diemsg} in USE"
- fi
- fi
-
- # add some warnings about optional functionality
- if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
- ewarn "IMAP quota display will not work correctly without GD support in PHP."
- ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
- ewarn
- fi
- use ldap || ewarn "PHP with USE=\"ldap\" is required for using LDAP addressbooks."
- use ssl || ewarn "PHP with USE=\"ssl\" is required for IMAPS/STMPS functionality."
- use spell || ewarn "PHP with USE=\"curl ssl\" required for spellchecker functionality."
-
- webapp_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-no-sockets-check.patch
- mv config/db.inc.php{.dist,}
- mv config/main.inc.php{.dist,}
-}
-
-src_install () {
- webapp_src_preinst
- dodoc CHANGELOG INSTALL README UPGRADING
-
- cp -R [[:lower:]]* SQL "${D}/${MY_HTDOCSDIR}"
-
- webapp_serverowned "${MY_HTDOCSDIR}"/logs
- webapp_serverowned "${MY_HTDOCSDIR}"/temp
-
- webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_postupgrade_txt en UPGRADING
- webapp_src_install
-}