summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberger <david.heidelberger@ixit.cz>2013-08-09 12:29:32 +0200
committerDavid Heidelberger <david.heidelberger@ixit.cz>2013-08-09 12:29:32 +0200
commit6ba9977fc6f5e825321ed32904f5eaa5473b350e (patch)
treecd7ea4b1b4d9d10182894d548012eda9a28f042d
parentx11-drivers/ati-drivers: add patch to fix 13.8-beta proc permissions. (diff)
downloadx11-6ba9977fc6f5e825321ed32904f5eaa5473b350e.tar.gz
x11-6ba9977fc6f5e825321ed32904f5eaa5473b350e.tar.bz2
x11-6ba9977fc6f5e825321ed32904f5eaa5473b350e.zip
app-benchmarks/glmark2: bump p280, new wayland supported, fixed build without patching
Package-Manager: portage-2.2.0_alpha195
-rw-r--r--app-benchmarks/glmark2/Manifest1
-rw-r--r--app-benchmarks/glmark2/glmark2-2012.12_p280.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-benchmarks/glmark2/Manifest b/app-benchmarks/glmark2/Manifest
index 688954fd..b816b80f 100644
--- a/app-benchmarks/glmark2/Manifest
+++ b/app-benchmarks/glmark2/Manifest
@@ -1 +1,2 @@
DIST glmark2-2012.12_p278.tar.gz 7778563 SHA256 e77a5026c108c4272986f9f0ccdc1474292c19192705ec984ceed8db44dd3d2e SHA512 a998b23819538cc29363aa95f5ad8a9252fa90950e37796f59577fdde2c3374e98eb847d44fb2d75e7ec955f0f1146aec1f5ac91024dc03b74e7afa8ce266851 WHIRLPOOL 84db3c7b5c368edb4a8222f49c7d2fef79e30c9b65e038b835b566cc208d4a6bd1a068707a780f917c27884182841fd0739326083580566fffb4e560339d3183
+DIST glmark2-2012.12_p280.tar.gz 7778627 SHA256 b4d675928d60a464ee23bc713d9088c96bcf81008117b791a314bcb764900928 SHA512 4b7b5d03a85d24f88fc7f33b7a28b2dff90ccc3d8752e99ee17e7fd64c4e392bf8016e67688e37b60c3d0707075e39389cd1f704c88fc18f85ba73372486feaa WHIRLPOOL a2349b166ccae2a9430ae273dcb55fc5149c19f473c1207f8a5848f13dfb53ef18c90cb9c6b1bc83f56bd3b4790414d1ed461ea290b30811707956e30b11b1e5
diff --git a/app-benchmarks/glmark2/glmark2-2012.12_p280.ebuild b/app-benchmarks/glmark2/glmark2-2012.12_p280.ebuild
new file mode 100644
index 00000000..d6ce2ea3
--- /dev/null
+++ b/app-benchmarks/glmark2/glmark2-2012.12_p280.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit waf-utils python-single-r1
+
+DESCRIPTION="Opengl test suite"
+HOMEPAGE="https://launchpad.net/glmark2"
+SRC_URI="http://bazaar.launchpad.net/~glmark2-dev/glmark2/trunk/tarball/280 -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+IUSE="drm +gles2 opengl wayland X"
+
+RDEPEND="media-libs/libpng
+ media-libs/mesa[gles2?]
+ X? ( x11-libs/libX11 )
+ wayland? ( >=dev-libs/wayland-1.2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( opengl gles2 )
+ || ( drm wayland X )"
+
+S="${WORKDIR}/~${PN}-dev/${PN}/trunk/"
+
+src_prepare() {
+ rm -rf "${S}/src/libpng"
+ sed -i "s/libpng15/libpng/g" "${S}/wscript" # allow build with >= libpng:1.6
+}
+
+src_configure() {
+ : ${WAF_BINARY:="${S}/waf"}
+
+ local myconf
+
+ if use X; then
+ if use opengl; then
+ myconf+="x11-gl"
+ fi
+ if use opengl && use gles2; then
+ myconf+=","
+ fi
+ if use gles2; then
+ myconf+="x11-glesv2"
+ fi
+
+ fi
+ if use drm; then
+ if use X; then
+ myconf+=","
+ fi
+ if use opengl; then
+ myconf+="drm-gl"
+ fi
+ if use opengl && use gles2; then
+ myconf+=","
+ fi
+ if use gles2; then
+ myconf+="drm-glesv2"
+ fi
+
+ fi
+ if use wayland; then
+ if use X || use drm; then
+ myconf+=","
+ fi
+ if use opengl; then
+ myconf+="wayland-gl"
+ fi
+ if use opengl && use gles2; then
+ myconf+=","
+ fi
+ if use gles2; then
+ myconf+="wayland-glesv2"
+ fi
+
+ fi
+
+ # it does not know --libdir specification, dandy huh
+ CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" "${WAF_BINARY}" \
+ --prefix=/usr \
+ --with-flavors ${myconf} \
+ configure || die "configure failed"
+}