summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-03-23 12:14:55 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-03-23 12:14:55 +0000
commit4ae6b08fb96f62aa353ca717f830e7f4bf6cdc5e (patch)
tree2d04411a7cd777109269b13aa74456b7d2d9d7e2 /sys-kernel/xen-sources/xen-sources-2.6.9999.ebuild
parentReleasing 2.6.18-12 (diff)
downloadxen-4ae6b08fb96f62aa353ca717f830e7f4bf6cdc5e.tar.gz
xen-4ae6b08fb96f62aa353ca717f830e7f4bf6cdc5e.tar.bz2
xen-4ae6b08fb96f62aa353ca717f830e7f4bf6cdc5e.zip
Add live xen-sources
(Portage version: 2.2_rc26/svn/Linux x86_64) svn path=/overlay/; revision=83
Diffstat (limited to 'sys-kernel/xen-sources/xen-sources-2.6.9999.ebuild')
-rw-r--r--sys-kernel/xen-sources/xen-sources-2.6.9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-kernel/xen-sources/xen-sources-2.6.9999.ebuild b/sys-kernel/xen-sources/xen-sources-2.6.9999.ebuild
new file mode 100644
index 0000000..2a8b1b2
--- /dev/null
+++ b/sys-kernel/xen-sources/xen-sources-2.6.9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xen-sources/xen-sources-2.6.21.ebuild,v 1.3 2008/08/31 17:44:43 rbu Exp $
+
+ETYPE="sources"
+UNIPATCH_STRICTORDER="1"
+K_NOUSENAME="yes"
+K_PREPATCHED="yes"
+
+inherit kernel-2
+detect_version
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/jeremy/xen.git"
+EGIT_BRANCH="xen/dom0/hackery"
+
+inherit git
+
+DESCRIPTION="Full sources for a dom0/domU Linux kernel to run under Xen"
+HOMEPAGE="http://xen.org/"
+IUSE=""
+KEYWORDS=""
+
+
+
+DEPEND="${DEPEND} >=sys-devel/binutils-2.17"
+
+src_unpack() {
+ git_src_unpack
+ cd "${EGIT_STORE_DIR}/${EGIT_PROJECT}"
+ local last_commit_abbrev=$(git log -n 1 --no-color --pretty='format:%h')
+ EXTRAVERSION="-xen.git-${last_commit_abbrev}"
+ S=${WORKDIR}/${EGIT_PROJECT}
+ cd "${S}"
+ unpack_set_extraversion
+}