summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-02-03 13:41:17 +0000
committerSteve Dibb <beandog@gentoo.org>2010-02-03 13:41:17 +0000
commitf1077f05773037ea78d2d62c7367cdc3eecd6e09 (patch)
tree889c667d3b84911b9a4724a6d7aee27b377b44c7 /import.ebuild_arch.php
parentUse singleton (diff)
downloadznurt-org-backend-f1077f05773037ea78d2d62c7367cdc3eecd6e09.tar.gz
znurt-org-backend-f1077f05773037ea78d2d62c7367cdc3eecd6e09.tar.bz2
znurt-org-backend-f1077f05773037ea78d2d62c7367cdc3eecd6e09.zip
Stop extending PortageTree and use singleton instead
git-svn-id: file:///var/svn/portage@80 3218660a-b0cf-4799-a991-8ddcc5b9e0f3
Diffstat (limited to 'import.ebuild_arch.php')
-rw-r--r--import.ebuild_arch.php4
1 files changed, 1 insertions, 3 deletions
diff --git a/import.ebuild_arch.php b/import.ebuild_arch.php
index ab9e77b..797f041 100644
--- a/import.ebuild_arch.php
+++ b/import.ebuild_arch.php
@@ -3,8 +3,7 @@
require_once 'header.php';
if(!$tree) {
- require_once 'class.portage.tree.php';
- $tree = new PortageTree();
+ $tree =& PortageTree::singleton();
}
require_once 'class.portage.category.php';
@@ -15,7 +14,6 @@
// $qa = true;
// Get the arches
- $tree = new PortageTree();
$arr_arches = $tree->getArches();
// Find all the ebuilds that are missing ebuild arch