summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'import.ebuild_arch.php')
-rw-r--r--import.ebuild_arch.php4
1 files changed, 1 insertions, 3 deletions
diff --git a/import.ebuild_arch.php b/import.ebuild_arch.php
index ab9e77b..797f041 100644
--- a/import.ebuild_arch.php
+++ b/import.ebuild_arch.php
@@ -3,8 +3,7 @@
require_once 'header.php';
if(!$tree) {
- require_once 'class.portage.tree.php';
- $tree = new PortageTree();
+ $tree =& PortageTree::singleton();
}
require_once 'class.portage.category.php';
@@ -15,7 +14,6 @@
// $qa = true;
// Get the arches
- $tree = new PortageTree();
$arr_arches = $tree->getArches();
// Find all the ebuilds that are missing ebuild arch