summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-04 09:44:51 +0100
committerMichał Górny <mgorny@gentoo.org>2014-12-04 09:44:51 +0100
commit5bf388dd85865798525b150b76035389554a9e02 (patch)
tree0932f56be16e0ad77c905bd3dbc071256faa3e43 /sys-devel
parentsys-devel/gcc: Remove defunct setup_multilib_osdirnames() (diff)
downloadmgorny-5bf388dd85865798525b150b76035389554a9e02.tar.gz
mgorny-5bf388dd85865798525b150b76035389554a9e02.tar.bz2
mgorny-5bf388dd85865798525b150b76035389554a9e02.zip
sys-devel/gcc: Clean up USE=multilib, add REQUIRED_USE for mips
Package-Manager: portage-2.2.14
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-4.9.2-r100.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-devel/gcc/gcc-4.9.2-r100.ebuild b/sys-devel/gcc/gcc-4.9.2-r100.ebuild
index 2ab3ffd..eb7b8b1 100644
--- a/sys-devel/gcc/gcc-4.9.2-r100.ebuild
+++ b/sys-devel/gcc/gcc-4.9.2-r100.ebuild
@@ -35,8 +35,7 @@ SLOT="${PV%.*}"
KEYWORDS="~amd64 ~x86"
IUSE="altivec +cxx doc fixed-point +fortran go graphite hardened libssp
- multilib +nls +nptl objc objc-gc objc++ +openmp +pie +sanitize
- test vanilla"
+ +nls +nptl objc objc-gc objc++ +openmp +pie +sanitize test vanilla"
RDEPEND="
>=dev-libs/gmp-4.3.2
@@ -70,6 +69,11 @@ REQUIRED_USE="
hardened? ( pie !vanilla )
objc++? ( cxx )
pie? ( !vanilla )"
+# Don't have fine-tuned switching of MIPS ABIs -- either one or all.
+REQUIRED_USE="${REQUIRED_USE}
+ abi_mips_o32? ( abi_mips_n32? ( abi_mips_n64 ) )
+ abi_mips_o32? ( abi_mips_n64? ( abi_mips_n32 ) )
+ abi_mips_n32? ( abi_mips_n64? ( abi_mips_o32 ) )"
# Custom magic.
RESTRICT="strip"
@@ -348,7 +352,6 @@ src_configure() {
gcc_abis=${gcc_abis[*]}
myconf+=(
- --enable-multilib
--with-multilib-list="${gcc_abis// /,}"
--with-abi="$(get_gcc_amd64_abi "${DEFAULT_ABI}")"
)