summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-19 01:54:38 -0400
committerSam James <sam@gentoo.org>2024-03-19 06:05:55 +0000
commitcc04e9b38ec9b7b714f6f5d33e3c6f262d38ddea (patch)
tree2f164668ffbd50bdbd61a2e21cacce2632a9d33e
parentdev-build/meson: add a blocker on versions of muon with the manpage (diff)
downloadgentoo-master.tar.gz
gentoo-master.tar.bz2
gentoo-master.zip
games-action/supertuxkart: mark as LTO-unsafe, strict-aliasing unsafeHEADmaster
Includes bundled sci-physics/bullet which has its own bug... Closes: https://bugs.gentoo.org/858521 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-action/supertuxkart/supertuxkart-1.3.ebuild15
-rw-r--r--games-action/supertuxkart/supertuxkart-1.4-r1.ebuild15
2 files changed, 26 insertions, 4 deletions
diff --git a/games-action/supertuxkart/supertuxkart-1.3.ebuild b/games-action/supertuxkart/supertuxkart-1.3.ebuild
index 54504fdfec32..d3a6aa690718 100644
--- a/games-action/supertuxkart/supertuxkart-1.3.ebuild
+++ b/games-action/supertuxkart/supertuxkart-1.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake desktop xdg
+inherit cmake desktop flag-o-matic xdg
MY_P="SuperTuxKart-${PV}-src"
DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
@@ -63,6 +63,17 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/858521
+ # https://github.com/supertuxkart/stk-code/issues/5035
+ #
+ # The issue is bundled code from sci-physics/bullet which is unlikely to
+ # be debundled.
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DUSE_SQLITE3=$(usex sqlite)
-DUSE_SYSTEM_ANGELSCRIPT=ON
diff --git a/games-action/supertuxkart/supertuxkart-1.4-r1.ebuild b/games-action/supertuxkart/supertuxkart-1.4-r1.ebuild
index 7b2fcde8f196..85252331bd59 100644
--- a/games-action/supertuxkart/supertuxkart-1.4-r1.ebuild
+++ b/games-action/supertuxkart/supertuxkart-1.4-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake desktop xdg
+inherit cmake desktop flag-o-matic xdg
MY_P="SuperTuxKart-${PV}-src"
DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
@@ -59,6 +59,17 @@ PATCHES=(
)
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/858521
+ # https://github.com/supertuxkart/stk-code/issues/5035
+ #
+ # The issue is bundled code from sci-physics/bullet which is unlikely to
+ # be debundled.
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DUSE_SQLITE3=$(usex sqlite)
-DUSE_SYSTEM_ANGELSCRIPT=ON