summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-04 04:33:01 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-04 04:45:26 +0200
commit00133f63c1e714c4ff36334ff3037ddf52ea1d4c (patch)
tree1fc972d9f7023bd32ff27434dc50d5e06651ae6a
parentmedia-libs/mutagen: Bump to 1.47.0 (diff)
downloadgentoo-00133f63c1e714c4ff36334ff3037ddf52ea1d4c.tar.gz
gentoo-00133f63c1e714c4ff36334ff3037ddf52ea1d4c.tar.bz2
gentoo-00133f63c1e714c4ff36334ff3037ddf52ea1d4c.zip
dev-python/pyaml: Bump to 23.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyaml/Manifest1
-rw-r--r--dev-python/pyaml/pyaml-23.9.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyaml/Manifest b/dev-python/pyaml/Manifest
index c0d8db158a8c..db647b223d74 100644
--- a/dev-python/pyaml/Manifest
+++ b/dev-python/pyaml/Manifest
@@ -1 +1,2 @@
DIST pyaml-23.7.0.tar.gz 20805 BLAKE2B 797b2b5d2121f3b0f67445d4b3a55b13d0716d5eddd5dc83a08b767d293b486e9985203f4e2571a7c8d3010b9cac9093e9353517f6414cd5b89cdcfe5d39c85a SHA512 edbe58a3a7f1216a2463ac56af829c38b12b7194429691a92cb7f28ca926094e324d6e44d3fb64be40239dc8a6dc61d72946b107f5210ca83e73dec18b1428ef
+DIST pyaml-23.9.1.tar.gz 21479 BLAKE2B dd684dd290cb3666ff823782d5252fea663ebd8801112765a1c4d18e1020072235a61f9d04df77da07bfb53074b1f3ed6a3a69776282c601768d14e79bb2ce41 SHA512 697ec54818d1c9117af768b2dd9e9269d78cf64416ea35673bee6b874f7b712be95467cdab73552c7105c38be73edb0a9a91fa924b191def7e39ed86b0eb8fd9
diff --git a/dev-python/pyaml/pyaml-23.9.1.ebuild b/dev-python/pyaml/pyaml-23.9.1.ebuild
new file mode 100644
index 000000000000..a49398baeb97
--- /dev/null
+++ b/dev-python/pyaml/pyaml-23.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="
+ https://github.com/mk-fg/pretty-yaml/
+ https://pypi.org/project/pyaml/
+"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest