summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-11 20:26:45 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-22 13:05:37 -0400
commit00182d44052ad19b2ba2cb18cbf9ecc94f37eaa1 (patch)
tree7f3a43ad03a20579ef05b5ede339f62b4d60122f
parentgames-board/pychess: 1.0.4_alpha1 (diff)
downloadgentoo-00182d44052ad19b2ba2cb18cbf9ecc94f37eaa1.tar.gz
gentoo-00182d44052ad19b2ba2cb18cbf9ecc94f37eaa1.tar.bz2
gentoo-00182d44052ad19b2ba2cb18cbf9ecc94f37eaa1.zip
gnome-base/gdm: Version bump to 44.0
Closes: https://github.com/gentoo/gentoo/pull/30301 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-base/gdm/Manifest1
-rw-r--r--gnome-base/gdm/files/gdm-44.0-meson-allow-building-with-elogind.patch208
-rw-r--r--gnome-base/gdm/gdm-44.0.ebuild215
-rw-r--r--gnome-base/gdm/metadata.xml1
4 files changed, 424 insertions, 1 deletions
diff --git a/gnome-base/gdm/Manifest b/gnome-base/gdm/Manifest
index a9cb79bf2bc0..12ea64d01997 100644
--- a/gnome-base/gdm/Manifest
+++ b/gnome-base/gdm/Manifest
@@ -1,2 +1,3 @@
DIST gdm-43.0.tar.xz 830668 BLAKE2B cd9fa9864ba075a85d16128ce2faba9c360357d900719c8e7cbb6c638f91750ff80ef0d970b24d0d858aa56f8ab95b8cac0d93624bcced8e6f98ca2d1f06fbc3 SHA512 e3eaa7a50e224939b6e535963171a800bb175ed9480a88ce14034929760dd579b91c4f3117be6a4404b2de13afdee881dafe09695eebf42872d4a13fbc5fb8ba
+DIST gdm-44.0.tar.xz 846848 BLAKE2B ce81771b119c912be0557e21db666aa99e61eb34bbbbd03a5c341a68eb060e7a956b95eeff5450a9bb879dbb177b11db65596e7cc3e8627e09d1fccd6cfe5c30 SHA512 eab556d0cab43ce4fe04b918f22281831f1dd8de836866de009884a637f11c83a626cdedb46cee5efb53cf1ad8139aa6e9568fd90a4d01704605347deca7bc2c
DIST tango-gentoo-v1.1.tar.gz 29322 BLAKE2B 83fa2bf37727e60851dd679054fe1b153ebfea58c9a9a40f891f7d68d3b047b02e8effa1d1b4e08d64500a2072ce7200f159c92a352da7124de27e1b05bb6027 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045
diff --git a/gnome-base/gdm/files/gdm-44.0-meson-allow-building-with-elogind.patch b/gnome-base/gdm/files/gdm-44.0-meson-allow-building-with-elogind.patch
new file mode 100644
index 000000000000..930352a9c32a
--- /dev/null
+++ b/gnome-base/gdm/files/gdm-44.0-meson-allow-building-with-elogind.patch
@@ -0,0 +1,208 @@
+https://gitlab.gnome.org/GNOME/gdm/-/merge_requests/113
+
+From e4e96e9ac55481bd2cae2c7ca33a1d516ad1b879 Mon Sep 17 00:00:00 2001
+From: Dudemanguy <random342@airmail.cc>
+Date: Mon, 5 Oct 2020 18:41:55 -0500
+Subject: [PATCH] meson: allow building with elogind
+
+Currently, the GDM meson build has a hard dependency on systemd.
+However, GDM can function just fine if one is using elogind. This allows
+a user to build GDM against libelogind and also disable the systemd
+system and user units.
+---
+ common/meson.build | 2 +-
+ data/meson.build | 62 +++++++++++++++++++++++++++-------------------
+ libgdm/meson.build | 2 +-
+ meson.build | 36 +++++++++++++++++++--------
+ meson_options.txt | 5 ++--
+ 5 files changed, 67 insertions(+), 40 deletions(-)
+
+diff --git a/common/meson.build b/common/meson.build
+index 074dd92e..bca58f7c 100644
+--- a/common/meson.build
++++ b/common/meson.build
+@@ -11,7 +11,7 @@ libgdmcommon_src = files(
+ )
+
+ libgdmcommon_deps = [
+- libsystemd_dep,
++ logind_dep,
+ gobject_dep,
+ gio_dep,
+ gio_unix_dep,
+diff --git a/data/meson.build b/data/meson.build
+index 2dec4c23..c3452e1c 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -164,41 +164,53 @@ else
+ service_config.set('PLYMOUTH_QUIT_SERVICE', '')
+ endif
+
+-if get_option('systemdsystemunitdir') != ''
+- systemd_systemunitdir = get_option('systemdsystemunitdir')
+-else
+- systemd_systemunitdir = systemd_dep.get_pkgconfig_variable('systemdsystemunitdir')
++systemdsystemunitdir = get_option('systemdsystemunitdir')
++if systemdsystemunitdir != 'no'
++ assert(systemd_dep.found(), 'systemd required but not found, please provide a valid systemd system unit dir or disable it')
++ if get_option('systemdsystemunitdir') != ''
++ systemd_systemunitdir = get_option('systemdsystemunitdir')
++ else
++ systemd_systemunitdir = systemd_dep.get_pkgconfig_variable('systemdsystemunitdir')
++ endif
+ endif
+
+-if get_option('systemduserunitdir') != ''
+- systemd_userunitdir = get_option('systemduserunitdir')
+-else
+- systemd_userunitdir = systemd_dep.get_pkgconfig_variable('systemduserunitdir',
+- define_variable: ['prefix', get_option('prefix')])
++systemduserunitdir = get_option('systemduserunitdir')
++if systemduserunitdir != 'no'
++ assert(systemd_dep.found(), 'systemd required but not found, please provide a valid systemd user unit dir or disable it')
++ if get_option('systemduserunitdir') != ''
++ systemd_userunitdir = get_option('systemduserunitdir')
++ else
++ systemd_userunitdir = systemd_dep.get_pkgconfig_variable('systemduserunitdir',
++ define_variable: ['prefix', get_option('prefix')])
++ endif
+ endif
+
+-configure_file(
+- input: 'gdm.service.in',
+- output: '@BASENAME@',
+- configuration: service_config,
+- install_dir: systemd_systemunitdir,
+- format: 'cmake'
+-)
++if systemdsystemunitdir != 'no'
++ configure_file(
++ input: 'gdm.service.in',
++ output: '@BASENAME@',
++ configuration: service_config,
++ install_dir: systemd_systemunitdir,
++ format: 'cmake'
++ )
++endif
+
+ gdm_gnome_session_wanted_targets = []
+ foreach component: gdm_gnome_user_session_wanted_components
+ gdm_gnome_session_wanted_targets += 'Wants=@0@.target'.format(component)
+ endforeach
+
+-configure_file(
+- input: 'session.conf.in',
+- output: 'session.conf',
+- configuration: {
+- 'requires_component': gdm_gnome_shell_component,
+- 'wants_required_components': '\n'.join(gdm_gnome_session_wanted_targets),
+- },
+- install_dir: systemd_userunitdir / 'gnome-session@gnome-login.target.d',
+-)
++if systemduserunitdir != 'no'
++ configure_file(
++ input: 'session.conf.in',
++ output: 'session.conf',
++ configuration: {
++ 'requires_component': gdm_gnome_shell_component,
++ 'wants_required_components': '\n'.join(gdm_gnome_session_wanted_targets),
++ },
++ install_dir: systemd_userunitdir / 'gnome-session@gnome-login.target.d',
++ )
++endif
+
+ # XSession
+ if get_option('gdm-xsession')
+diff --git a/libgdm/meson.build b/libgdm/meson.build
+index 3f8cafbb..83e95151 100644
+--- a/libgdm/meson.build
++++ b/libgdm/meson.build
+@@ -56,7 +56,7 @@ libgdm_deps = [
+ glib_dep,
+ gio_dep,
+ gio_unix_dep,
+- libsystemd_dep,
++ logind_dep,
+ libgdmcommon_dep,
+ ]
+
+diff --git a/meson.build b/meson.build
+index 57116f2a..db4ecfd6 100644
+--- a/meson.build
++++ b/meson.build
+@@ -99,17 +99,30 @@ xdmcp_dep = cc.find_library('Xdmcp', required: get_option('xdmcp'))
+ if xdmcp_dep.found() and get_option('tcp-wrappers')
+ libwrap_dep = cc.find_library('wrap')
+ endif
+-# systemd
+-systemd_dep = dependency('systemd')
+-libsystemd_dep = dependency('libsystemd')
+-systemd_multiseat_x = find_program('systemd-multi-seat-x',
+- required: false,
+- dirs: [
+- systemd_dep.get_pkgconfig_variable('systemdutildir'),
+- '/lib/systemd',
+- '/usr/lib/systemd',
+- ])
+-systemd_x_server = systemd_multiseat_x.found()? systemd_multiseat_x.path() : '/lib/systemd/systemd-multi-seat-x'
++
++logind_provider = get_option('logind-provider')
++systemd_dep = dependency('systemd', required: false)
++if logind_provider == 'systemd'
++ libsystemd_dep = dependency('libsystemd')
++ logind_dep = libsystemd_dep
++ if meson.version().version_compare('>= 0.53')
++ systemd_multiseat_x = find_program('systemd-multi-seat-x',
++ required: false,
++ dirs: [
++ systemd_dep.get_pkgconfig_variable('systemdutildir'),
++ '/lib/systemd',
++ '/usr/lib/systemd',
++ ])
++ else
++ systemd_multiseat_x = find_program('systemd-multi-seat-x', required: false)
++ endif
++ systemd_x_server = systemd_multiseat_x.found()? systemd_multiseat_x.path() : '/lib/systemd/systemd-multi-seat-x'
++ else
++ elogind_dep = dependency('libelogind')
++ logind_dep = elogind_dep
++ systemd_x_server = 'disabled'
++ endif
++
+ # Plymouth
+ plymouth_dep = dependency('ply-boot-client', required: get_option('plymouth'))
+ # Check for Solaris auditing API (ADT)
+@@ -319,6 +332,7 @@ summary({
+ 'PAM Syslog': have_pam_syslog,
+ 'Supports PAM Extensions': pam_extensions_supported,
+ 'SeLinux': libselinux_dep.found(),
++ 'Logind Provider': get_option('logind-provider'),
+ 'Use GDM Xsession': get_option('gdm-xsession'),
+ 'Use UserDisplayServer': get_option('user-display-server'),
+ 'Use SystemdJournal': get_option('systemd-journal'),
+diff --git a/meson_options.txt b/meson_options.txt
+index 14e0b908..5135d7d6 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -12,6 +12,7 @@ option('initial-vt', type: 'integer', value: 1, description: 'Initial virtual te
+ option('ipv6', type: 'boolean', value: false, description: 'Enables compilation of IPv6 code.')
+ option('lang-file', type: 'string', value: '', description: 'File containing default language settings.')
+ option('libaudit', type: 'feature', value: 'auto', description: 'Add Linux audit support.')
++option('logind-provider', type: 'combo', choices: ['systemd', 'elogind'], value: 'systemd', description: 'Which logind library to use.')
+ option('log-dir', type: 'string', value: '/var/log/gdm', description: 'Log directory.')
+ option('pam-mod-dir', type: 'string', value: '', description: 'Directory to install PAM modules in.')
+ option('pam-prefix', type: 'string', value: '', description: 'Specify where PAM files go.')
+@@ -27,8 +28,8 @@ option('solaris', type: 'boolean', value: false, description: 'Build for Solaris
+ option('split-authentication', type: 'boolean', value: true, description: 'Enable multiple simultaneous PAM conversations during login.')
+ option('sysconfsubdir', type: 'string', value: 'gdm', description: 'Directory name used under sysconfdir.')
+ option('systemd-journal', type: 'boolean', value: true, description: 'Use journald support.')
+-option('systemdsystemunitdir', type: 'string', value: '', description: 'Directory for systemd service files.')
+-option('systemduserunitdir', type: 'string', value: '', description: 'Directory for systemd user service files.')
++option('systemdsystemunitdir', type: 'string', value: '', description: 'Directory for systemd service files, or \'no\' to disable.')
++option('systemduserunitdir', type: 'string', value: '', description: 'Directory for systemd user service files, or \'no\' to disable.')
+ option('tcp-wrappers', type: 'boolean', value: false, description: 'Use TCP wrappers.')
+ option('udev-dir', type: 'string', value: '', description: 'Directory for udev rules file.')
+ option('user', type: 'string', value: 'gdm', description: 'GDM\'s username.')
+--
+2.39.2
+
diff --git a/gnome-base/gdm/gdm-44.0.ebuild b/gnome-base/gdm/gdm-44.0.ebuild
new file mode 100644
index 000000000000..be6bdc9ecea6
--- /dev/null
+++ b/gnome-base/gdm/gdm-44.0.ebuild
@@ -0,0 +1,215 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop gnome2 meson pam readme.gentoo-r1 systemd udev
+
+DESCRIPTION="GNOME Display Manager for managing graphical display servers and user logins"
+HOMEPAGE="https://wiki.gnome.org/Projects/GDM https://gitlab.gnome.org/GNOME/gdm"
+
+SRC_URI="${SRC_URI}
+ branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+"
+
+LICENSE="
+ GPL-2+
+ branding? ( CC-BY-SA-4.0 )
+"
+
+SLOT="0"
+
+IUSE="accessibility audit bluetooth-sound branding elogind fprint plymouth selinux systemd tcpd test wayland"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="^^ ( elogind systemd )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+# dconf, dbus and g-s-d are needed at install time for dconf update
+# keyutils is automagic dep that makes autologin unlock login keyring
+# when all the passwords match (disk encryption, user pw and login keyring)
+# dbus-run-session used at runtime
+COMMON_DEPEND="
+ virtual/udev
+ >=dev-libs/libgudev-232:=
+ >=dev-libs/glib-2.56:2
+ >=x11-libs/gtk+-2.91.1:3
+ >=media-libs/libcanberra-0.4[gtk3]
+ >=sys-apps/accountsservice-0.6.35
+ x11-libs/libxcb
+ sys-apps/keyutils:=
+ selinux? ( sys-libs/libselinux )
+
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-base/xorg-server[-minimal]
+ x11-libs/libXdmcp
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+
+ systemd? ( >=sys-apps/systemd-186:0=[pam] )
+ elogind? ( >=sys-auth/elogind-239.3[pam] )
+
+ plymouth? ( sys-boot/plymouth )
+ audit? ( sys-process/audit )
+
+ sys-libs/pam
+ sys-auth/pambase[elogind?,systemd?]
+
+ >=gnome-base/dconf-0.20
+ >=gnome-base/gnome-settings-daemon-3.1.4
+ gnome-base/gsettings-desktop-schemas
+ sys-apps/dbus
+
+ >=x11-misc/xdg-utils-1.0.2-r3
+
+ >=dev-libs/gobject-introspection-0.9.12:=
+"
+# XXX: These deps are from session and desktop files in data/ directory
+# fprintd is used via dbus by gdm-fingerprint-extension
+RDEPEND="${COMMON_DEPEND}
+ acct-group/gdm
+ acct-user/gdm
+ >=gnome-base/gnome-session-3.6
+ >=gnome-base/gnome-shell-3.1.90
+ x11-apps/xhost
+
+ accessibility? (
+ >=app-accessibility/orca-3.10
+ gnome-extra/mousetweaks
+ )
+ fprint? ( sys-auth/fprintd[pam] )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=gnome-base/dconf-0.20
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( >=dev-libs/check-0.9.4 )
+ app-text/yelp-tools
+"
+
+DOC_CONTENTS="
+ To start GDM at boot with systemd, run:\n
+ # systemctl enable gdm.service\n
+ \n
+ To start GDM at boot with OpenRC, set DISPLAYMANAGER=\"gdm\"\n
+ in /etc/conf.d/display-manager and enable the display-manager service:\n
+ # rc-update add display-manager\n
+ \n
+ For passwordless login to unlock your keyring, you need to install
+ sys-auth/pambase with USE=gnome-keyring and set an empty password
+ on your keyring. Use app-crypt/seahorse for that.\n
+ \n
+ You may need to install app-crypt/coolkey and sys-auth/pam_pkcs11
+ for smartcard support
+"
+
+PATCHES=(
+ # Add elogind support
+ "${FILESDIR}/${PN}-44.0-meson-allow-building-with-elogind.patch"
+)
+
+src_prepare() {
+ default
+
+ # Show logo when branding is enabled
+ use branding && eapply "${FILESDIR}/${PN}-3.30.3-logo.patch"
+}
+
+src_configure() {
+ # --with-initial-vt=7 conflicts with plymouth, bug #453392
+ # gdm-3.30 now reaps (stops) the login screen when the login VT isn't active, which
+ # saves on memory. However this means if we don't start on VT1, gdm doesn't start up
+ # before user manually goes to VT7. Thus as-is we can not keep gdm away from VT1,
+ # so lets try always having it in VT1 and see if that is an issue for people before
+ # hacking up workarounds for the initial start case.
+ local emesonargs=(
+ --localstatedir /var
+
+ -Ddefault-pam-config=exherbo
+ -Dgdm-xsession=true
+ -Dgroup=gdm
+ -Dipv6=true
+ $(meson_feature audit libaudit)
+ -Dlogind-provider=$(usex systemd systemd elogind)
+ -Dpam-mod-dir=$(getpam_mod_dir)
+ $(meson_feature plymouth)
+ -Drun-dir=/run/gdm
+ $(meson_feature selinux)
+ $(meson_use systemd systemd-journal)
+ $(meson_use tcpd tcp-wrappers)
+ -Dudev-dir=$(get_udevdir)/rules.d
+ -Duser=gdm
+ -Duser-display-server=true
+ $(meson_use wayland wayland-support)
+ -Dxdmcp=enabled
+ )
+
+ if use elogind; then
+ emesonargs+=(
+ -Dinitial-vt=7 # TODO: Revisit together with startDM.sh and other xinit talks; also ignores plymouth possibility
+ -Dsystemdsystemunitdir=no
+ -Dsystemduserunitdir=no
+ )
+ else
+ emesonargs+=(
+ -Dinitial-vt=1
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if ! use accessibility ; then
+ rm "${ED}"/usr/share/gdm/greeter/autostart/orca-autostart.desktop || die
+ fi
+
+ if ! use bluetooth-sound ; then
+ # Workaround https://gitlab.freedesktop.org/pulseaudio/pulseaudio/merge_requests/10
+ # bug #679526
+ insinto /var/lib/gdm/.config/pulse
+ doins "${FILESDIR}"/default.pa
+ fi
+
+ # install XDG_DATA_DIRS gdm changes
+ echo 'XDG_DATA_DIRS="/usr/share/gdm"' > 99xdg-gdm
+ doenvd 99xdg-gdm
+
+ use branding && newicon "${WORKDIR}/tango-gentoo-v1.1/scalable/gentoo.svg" gentoo-gdm.svg
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ local d ret
+
+ # bug #669146; gdm may crash if /var/lib/gdm subdirs are not owned by gdm:gdm
+ ret=0
+ ebegin "Fixing ${EROOT}/var/lib/gdm ownership"
+ chown --no-dereference gdm:gdm "${EROOT}/var/lib/gdm" || ret=1
+ for d in "${EROOT}/var/lib/gdm/"{.cache,.color,.config,.dbus,.local}; do
+ [[ ! -e "${d}" ]] || chown --no-dereference -R gdm:gdm "${d}" || ret=1
+ done
+ eend ${ret}
+
+ systemd_reenable gdm.service
+ readme.gentoo_print_elog
+
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/gnome-base/gdm/metadata.xml b/gnome-base/gdm/metadata.xml
index f3e676ca32ba..badb7ce5e45a 100644
--- a/gnome-base/gdm/metadata.xml
+++ b/gnome-base/gdm/metadata.xml
@@ -7,7 +7,6 @@
</maintainer>
<use>
<flag name="bluetooth-sound">Allow loading of bluetooth sound modules. This may be necessary for accessibility screen readers, but may cause bluetooth sound issues for users logging in.</flag>
- <flag name="elogind">Use <pkg>sys-auth/elogind</pkg> for session management</flag>
<flag name="fprint">Enables experimental fingerprint authentication using <pkg>sys-auth/fprintd</pkg></flag>
<flag name="plymouth">Enable support for smooth transition from <pkg>sys-boot/plymouth</pkg></flag>
</use>