summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-06 13:12:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-06 15:06:27 +0100
commit0030bb528b180f4571a18cec53469a276258327e (patch)
tree6f7ae858efd56d7b4152d88ea9e92547c29efcd0
parentdev-python/qiskit-aer: Remove old (diff)
downloadgentoo-0030bb528b180f4571a18cec53469a276258327e.tar.gz
gentoo-0030bb528b180f4571a18cec53469a276258327e.tar.bz2
gentoo-0030bb528b180f4571a18cec53469a276258327e.zip
dev-python/qiskit-terra: Fix rustworkx support
Fix qiskit-terra to support rustworkx, the new name of retworkx. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/qiskit-terra/qiskit-terra-0.22.0-r1.ebuild (renamed from dev-python/qiskit-terra/qiskit-terra-0.22.0.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/qiskit-terra/qiskit-terra-0.22.0.ebuild b/dev-python/qiskit-terra/qiskit-terra-0.22.0-r1.ebuild
index 7a0c507d8577..fd442eceacd3 100644
--- a/dev-python/qiskit-terra/qiskit-terra-0.22.0.ebuild
+++ b/dev-python/qiskit-terra/qiskit-terra-0.22.0-r1.ebuild
@@ -128,6 +128,11 @@ distutils_enable_tests pytest
# and an exact comparison of float switched to approximate comparison.
#PATCHES=( "${FILESDIR}/qiskit-terra-0.19.2-test-corrections.patch" )
+src_prepare() {
+ find -name '*.py' -exec sed -i -e 's:retworkx:rustworkx:' {} + || die
+ distutils-r1_src_prepare
+}
+
python_test() {
# We have to hide the source code directory so tests
# do not use these, but instead the compiled library.