summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-27 09:49:24 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-27 10:20:19 +0100
commit003cf3c72e49f59cd3dc8a957d49992698d85db2 (patch)
tree8c07fdcba302ca4e99f6aaeb6dff069477a8dba7
parentapp-admin/system-config-printer: Drop 1.5.12-r1 (diff)
downloadgentoo-003cf3c72e49f59cd3dc8a957d49992698d85db2.tar.gz
gentoo-003cf3c72e49f59cd3dc8a957d49992698d85db2.tar.bz2
gentoo-003cf3c72e49f59cd3dc8a957d49992698d85db2.zip
dev-python/lxml: Bump to 4.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lxml/Manifest1
-rw-r--r--dev-python/lxml/lxml-4.6.2.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/lxml/Manifest b/dev-python/lxml/Manifest
index bd0cc0f939d9..4237fe3cc16a 100644
--- a/dev-python/lxml/Manifest
+++ b/dev-python/lxml/Manifest
@@ -1 +1,2 @@
DIST lxml-4.6.1.tar.gz 946461 BLAKE2B b1ea8e15af1130b9f9683614bbc2480ec5008ad697f70536a332c1faf4bda4aa9525b2ef5d82d32c415c91e47ab54c7b3cb644e9a2933517946c3fc8ab7ec7c5 SHA512 3cc917e7535ac1be3db8939f72846313267c8b1f0adccc92a2155a160ed7299d0def718bdae1379e42398ca1b959b1130505597febca00f02cb87c8666f1f1c3
+DIST lxml-4.6.2.tar.gz 948652 BLAKE2B df6ec7e183df48c0edc6cce0fbdd6ab78eb8d1b7e8fb81a76bd9f4a24f05923c757d5b21f508be9be50c7bb187927c4e3a66146d480f2d40efc05388d26d3bf5 SHA512 81dcf5cade7b05c0e831beae7cdfbdb21e876fa55b23da98b89cbfa7960a4737efc13346ea3ade22a2448f20e036173cf5e32d43df6656c3231bfba07981f9ed
diff --git a/dev-python/lxml/lxml-4.6.2.ebuild b/dev-python/lxml/lxml-4.6.2.ebuild
new file mode 100644
index 000000000000..f2212f186272
--- /dev/null
+++ b/dev-python/lxml/lxml-4.6.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1 optfeature toolchain-funcs
+
+DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
+HOMEPAGE="https://lxml.de/ https://pypi.org/project/lxml/ https://github.com/lxml/lxml"
+SRC_URI="https://github.com/lxml/lxml/archive/${P}.tar.gz"
+S=${WORKDIR}/lxml-${P}
+
+LICENSE="BSD ElementTree GPL-2 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples +threads test"
+RESTRICT="!test? ( test )"
+
+# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
+RDEPEND="
+ >=dev-libs/libxml2-2.9.5
+ >=dev-libs/libxslt-1.1.28"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/cssselect[${PYTHON_USEDEP}] )
+ "
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.6.0-tests-pypy.patch
+)
+
+python_prepare_all() {
+ # avoid replacing PYTHONPATH in tests.
+ sed -i -e '/sys\.path/d' test.py || die
+
+ # don't use some random SDK on Darwin
+ sed -i -e '/_ldflags =/s/=.*isysroot.*darwin.*None/= None/' \
+ setupinfo.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ tc-export PKG_CONFIG
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cp -r -l src/lxml/tests "${BUILD_DIR}"/lib/lxml/ || die
+ cp -r -l src/lxml/html/tests "${BUILD_DIR}"/lib/lxml/html/ || die
+ ln -s "${S}"/doc "${BUILD_DIR}"/ || die
+
+ "${EPYTHON}" test.py -vv --all-levels -p || die "Test ${test} fails with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use doc; then
+ local DOCS=( README.rst *.txt doc/*.txt )
+ local HTML_DOCS=( doc/html/. )
+ fi
+ if use examples; then
+ dodoc -r samples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup as a parser backend" dev-python/beautifulsoup
+ optfeature "Translates CSS selectors to XPath 1.0 expressions" dev-python/cssselect
+}