summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-01 14:44:13 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-01 15:47:23 +0200
commit004c45b9e4488adaa0822725ab85802a94017126 (patch)
treea0de278d85a14e7876fa29d66be6c90909511e8b
parentdev-python/tox: Bump to 3.16.1 (diff)
downloadgentoo-004c45b9.tar.gz
gentoo-004c45b9.tar.bz2
gentoo-004c45b9.zip
dev-python/pyclipper: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyclipper/Manifest1
-rw-r--r--dev-python/pyclipper/pyclipper-1.2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyclipper/Manifest b/dev-python/pyclipper/Manifest
index c92dc0f4c841..4c5b84724627 100644
--- a/dev-python/pyclipper/Manifest
+++ b/dev-python/pyclipper/Manifest
@@ -1,2 +1,3 @@
DIST pyclipper-1.1.0.tar.gz 53916 BLAKE2B 53b7b6609d602cdcbd8c8f4ceaed999c97e155747f7daeb630333f18fd2719040d118c8fa3d0e60a1ccd92c20aecb355ec9d4f9c22f66dc07b14a919f981f667 SHA512 53371bc2e0439f72ac4ebf96f833c4451d2b1924d7f9cddcbac79a0a6d6bd95ac1fb3fb08e3ea3fcf3ffe22cd718d31c7c528016605b275a3e80642e58546d74
DIST pyclipper-1.1.0_p3.tar.gz 53353 BLAKE2B 1e510ab97ef98b83c763d4bc1154eb32f94bb035823ddcffef09fe32861c2384ccd6ffd29e5a31c0cabf71c801dd90d0176a68e93c6c2e2c9bff03c2be3fff33 SHA512 0b3c3f18593bafedaedf8a91411ba5d3d1c2ac55c949bca21e3a527ca0930eae5ea033a0f57337573a1106e2871a50dcb0176b959b98ad8ac58636c6d45f94a9
+DIST pyclipper-1.2.0.tar.gz 53504 BLAKE2B 611a86b4173838dc0c77ad765f1ab9d08e73b147936ec60fae63308d5bb0019b40479222b80565f3d3ba5337c1a436fa63306105bb3a698592160eb8b66f3014 SHA512 2b8966a695fd7916786ab7549f8c867aad1d4879f3d20b87d7a4b6e1fff8a36871a440795548e91256ff89e574c04be4390ffbd05bab6b0bb51441c7f8acf674
diff --git a/dev-python/pyclipper/pyclipper-1.2.0.ebuild b/dev-python/pyclipper/pyclipper-1.2.0.ebuild
new file mode 100644
index 000000000000..3efd8d8de2fc
--- /dev/null
+++ b/dev-python/pyclipper/pyclipper-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
+HOMEPAGE="https://github.com/fonttools/pyclipper"
+SRC_URI="https://github.com/fonttools/pyclipper/archive/${PV/_p/.post}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_p/.post}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV/_p/.post}"
+}