summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-07-06 09:08:26 +0200
committerHans de Graaff <graaff@gentoo.org>2021-07-06 09:49:09 +0200
commit004fd411cb031a08a3e66997ea6b1bdc67d0b126 (patch)
tree7d95f4382bba6a381985965c4dd994b6a082d2fd
parentdev-ruby/bsearch: add ruby30 (diff)
downloadgentoo-004fd411cb031a08a3e66997ea6b1bdc67d0b126.tar.gz
gentoo-004fd411cb031a08a3e66997ea6b1bdc67d0b126.tar.bz2
gentoo-004fd411cb031a08a3e66997ea6b1bdc67d0b126.zip
dev-ruby/bcrypt_pbkdf: cleanup
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/bcrypt_pbkdf/Manifest1
-rw-r--r--dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.1.ebuild43
-rw-r--r--dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.1.0.ebuild42
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-ruby/bcrypt_pbkdf/Manifest b/dev-ruby/bcrypt_pbkdf/Manifest
index a947cbc6de0c..878cebba36a2 100644
--- a/dev-ruby/bcrypt_pbkdf/Manifest
+++ b/dev-ruby/bcrypt_pbkdf/Manifest
@@ -1,3 +1,2 @@
DIST bcrypt_pbkdf-1.0.0.gem 24576 BLAKE2B 0d5b1d90d57dbae986fcbb92cabb0ea598d6b928dc97026e8d2078f41898e0c143544a004a561c0a392504baa4b845a27f9c1e19c369f6342f7ace9de7f04d3f SHA512 b582407617633f5277cde9251ed1fd2ca408ae8bd19cc73f107d7932bed38061dc0099d3033ff5def1b586507392c33d8c50815fb156322f0dd08fbbe4a8e967
-DIST bcrypt_pbkdf-1.0.1.gem 24576 BLAKE2B 7ccade2b5eeabcdcffe5c53bf8ed2e4163536229b7ccd356e173c0b2a27c720aa5429ea0081d2a3e7e7cfc52613c32a48529233156b56db4bbd48da61bbd9cdf SHA512 7caf65dc48ec9d51dbde7741b0960e2606129f888787db31fe36f3cf103d51f06156e942badb10310faa8ca9dcf8f7f8dd86358431942a6e2097714ae3462dee
DIST bcrypt_pbkdf-1.1.0.gem 24576 BLAKE2B 4fb9449c23c1a1caefbe7acae630eff9c6ee22b77d1eaed6475400ab2b37186d3f15b867cdad364daaaf27d6b817d6a2a49cfbf567a889264fdd64903f06cf89 SHA512 a7b9f123274a2f93e183be7339149b1df3b185331fdc63af58e342ae4bb734fdcf709214a50922218b837481349948e10ec879f9b8e1a6928b1b7b5617f83be5
diff --git a/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.1.ebuild b/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.1.ebuild
deleted file mode 100644
index 25f0fe94d727..000000000000
--- a/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements bcrypt_pdkfd (a variant of PBKDF2 with bcrypt-based PRF)"
-HOMEPAGE="https://github.com/net-ssh/bcrypt_pbkdf-ruby"
-
-LICENSE="MIT"
-SLOT="1"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( virtual/ruby-ssl )"
-
-all_ruby_prepare() {
- # Don't use a ruby-bundled version of libsodium
- sed -i -e '/rbnacl\/libsodium/ s:^:#:' test/bcrypt_pnkdf/engine_test.rb || die
-
- # Avoid unneeded rake-compiler dependency
- sed -e '/extensiontask/ s:^:#:' -e '/ExtensionTask/,/^end/ s:^:#:' \
- -e '/bundler/ s:^:#:' \
- -i Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/mri extconf.rb || die
-
- # Some methods may not be inlined on x86 but they are not defined either, bug 629164
- sed -i -e 's:-Wl,--no-undefined::' ext/mri/Makefile || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/mri
- cp ext/mri/bcrypt_pbkdf_ext.so lib/ || die
-}
diff --git a/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.1.0.ebuild b/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.1.0.ebuild
deleted file mode 100644
index 20942ab3e80c..000000000000
--- a/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.1.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements bcrypt_pdkfd (a variant of PBKDF2 with bcrypt-based PRF)"
-HOMEPAGE="https://github.com/net-ssh/bcrypt_pbkdf-ruby"
-
-LICENSE="MIT"
-SLOT="1"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( virtual/ruby-ssl )"
-
-all_ruby_prepare() {
- # Don't use a ruby-bundled version of libsodium
- sed -i -e '/rbnacl\/libsodium/ s:^:#:' test/bcrypt_pnkdf/engine_test.rb || die
-
- # Avoid unneeded rake-compiler dependency
- sed -e '/extensiontask/ s:^:#:' -e '/ExtensionTask/,/^end/ s:^:#:' \
- -e '/bundler/ s:^:#:' \
- -i Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/mri extconf.rb || die
-
- # Some methods may not be inlined on x86 but they are not defined either, bug 629164
- sed -i -e 's:-Wl,--no-undefined::' ext/mri/Makefile || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/mri
- cp ext/mri/bcrypt_pbkdf_ext.so lib/ || die
-}