summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-04-21 15:30:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-04-22 18:22:32 +0200
commit0055a28dc89a2df277e186e2346497556795ac66 (patch)
treebf9e16124ca868b1d4b0c589d416b330d1faa21f
parentkde-apps/okular: Fix musl build (implicit vasprintf decl) (diff)
downloadgentoo-0055a28dc89a2df277e186e2346497556795ac66.tar.gz
gentoo-0055a28dc89a2df277e186e2346497556795ac66.tar.bz2
gentoo-0055a28dc89a2df277e186e2346497556795ac66.zip
media-gfx/okularpart: Fix musl build (implicit vasprintf decl)
KDE-bug: https://bugs.kde.org/show_bug.cgi?id=398338 Upstream MR: https://invent.kde.org/graphics/okular/-/merge_requests/722 Cherry-picked from upstream's upstream: https://github.com/jlaurens/synctex/commit/4b0590e7d1817b004c71635f9e721edf1e368228 Closes: https://bugs.gentoo.org/927683 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-gfx/okularpart/files/okularpart-23.08.5-implicit-vasprintf.patch29
-rw-r--r--media-gfx/okularpart/okularpart-23.08.5-r1.ebuild1
2 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/okularpart/files/okularpart-23.08.5-implicit-vasprintf.patch b/media-gfx/okularpart/files/okularpart-23.08.5-implicit-vasprintf.patch
new file mode 100644
index 000000000000..685da3112291
--- /dev/null
+++ b/media-gfx/okularpart/files/okularpart-23.08.5-implicit-vasprintf.patch
@@ -0,0 +1,29 @@
+From a0f57bf7f984289c5b0ceefa2a784f97cd58428a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Germ=C3=A1n=20Poo-Caama=C3=B1o?= <gpoo@gnome.org>
+Date: Sat, 30 May 2020 16:15:27 -0400
+Subject: [PATCH] Fix implicit declaration of vasprintf
+
+Fix build when compiling with `-Werror=implicit-function-declaration`.
+---
+ core/synctex/synctex_parser.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/core/synctex/synctex_parser.c b/core/synctex/synctex_parser.c
+index 9eed566b3..a67006d39 100644
+--- a/core/synctex/synctex_parser.c
++++ b/core/synctex/synctex_parser.c
+@@ -55,6 +55,11 @@
+ * First level objects are sheets and forms, containing boxes, glues, kerns...
+ * The third tree allows to browse leaves according to tag and line.
+ */
++/* Declare _GNU_SOURCE for accessing vasprintf. For MSC compiler, vasprintf is
++ * defined in this file
++ */
++#define _GNU_SOURCE
++
+ #if defined(SYNCTEX_USE_LOCAL_HEADER)
+ #include "synctex_parser_local.h"
+ #else
+--
+2.44.0
+
diff --git a/media-gfx/okularpart/okularpart-23.08.5-r1.ebuild b/media-gfx/okularpart/okularpart-23.08.5-r1.ebuild
index fb9b00ce306c..ae6a4d671d88 100644
--- a/media-gfx/okularpart/okularpart-23.08.5-r1.ebuild
+++ b/media-gfx/okularpart/okularpart-23.08.5-r1.ebuild
@@ -61,6 +61,7 @@ PATCHES=(
"${FILESDIR}/${P}-tests.patch" # bug 734138
"${FILESDIR}/${P}-only.patch"
"${FILESDIR}/${P}-crashfix.patch" # KDE-bug 476207
+ "${FILESDIR}/${P}-implicit-vasprintf.patch" # bug 927683; pending upstream
)
src_configure() {