summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-05 20:19:09 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-05 20:37:01 +0100
commit006c567482a3a7b426a033ec0a674d470e57877c (patch)
treef43de3775390db3b9baa03382b2d94bcaf819eb8
parentnet-misc/openssh: Inherit user.eclass for egetshell (bug #708366) (diff)
downloadgentoo-006c567482a3a7b426a033ec0a674d470e57877c.tar.gz
gentoo-006c567482a3a7b426a033ec0a674d470e57877c.tar.bz2
gentoo-006c567482a3a7b426a033ec0a674d470e57877c.zip
dev-python/pycups: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pycups/pycups-1.9.73-r1.ebuild31
-rw-r--r--dev-python/pycups/pycups-1.9.73-r2.ebuild31
2 files changed, 4 insertions, 58 deletions
diff --git a/dev-python/pycups/pycups-1.9.73-r1.ebuild b/dev-python/pycups/pycups-1.9.73-r1.ebuild
index 739e5b77d606..2fc406f3ca50 100644
--- a/dev-python/pycups/pycups-1.9.73-r1.ebuild
+++ b/dev-python/pycups/pycups-1.9.73-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="Python bindings for the CUPS API"
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~sh sparc x86"
SLOT="0"
-IUSE="doc examples"
+IUSE="examples"
RDEPEND="
net-print/cups
@@ -23,33 +23,6 @@ DEPEND="
${RDEPEND}
"
-# epydoc kinda sucks and supports python2 only (it's dead too),
-# and since we're dealing with a binary module we need exact version
-# match. therefore, docbuilding *requires* any python2 being enabled.
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/epydoc[$(python_gen_usedep 'python2*')] )
-"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- # we can't use Makefile since it relies on hardcoded paths
- epydoc -o html --html cups || die "doc build failed"
- HTML_DOCS=( html/. )
- fi
-}
-
python_install_all() {
if use examples; then
dodoc -r examples
diff --git a/dev-python/pycups/pycups-1.9.73-r2.ebuild b/dev-python/pycups/pycups-1.9.73-r2.ebuild
index 5cc54abd0a77..f1ce8a33d076 100644
--- a/dev-python/pycups/pycups-1.9.73-r2.ebuild
+++ b/dev-python/pycups/pycups-1.9.73-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
inherit distutils-r1
DESCRIPTION="Python bindings for the CUPS API"
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~sh sparc x86"
SLOT="0"
-IUSE="doc examples"
+IUSE="examples"
RDEPEND="
net-print/cups
@@ -23,33 +23,6 @@ DEPEND="
${RDEPEND}
"
-# epydoc kinda sucks and supports python2 only (it's dead too),
-# and since we're dealing with a binary module we need exact version
-# match. therefore, docbuilding *requires* any python2 being enabled.
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/epydoc[$(python_gen_usedep 'python2*')] )
-"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- # we can't use Makefile since it relies on hardcoded paths
- epydoc -o html --html cups || die "doc build failed"
- HTML_DOCS=( html/. )
- fi
-}
-
python_install_all() {
if use examples; then
dodoc -r examples