summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 14:52:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 14:53:42 +0200
commit006cdf16e6b7f5a770b49d67f4e35a0c44761758 (patch)
tree517c4bdb4bafed005d5f6da8a3c8c1b8e4b6d434
parentdev-python/smartypants: Remove the live ebuild (diff)
downloadgentoo-006cdf16.tar.gz
gentoo-006cdf16.tar.bz2
gentoo-006cdf16.zip
dev-python/smartypants: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/smartypants/smartypants-2.0.1-r1.ebuild33
1 files changed, 17 insertions, 16 deletions
diff --git a/dev-python/smartypants/smartypants-2.0.1-r1.ebuild b/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
index c4a5c111cae5..826aa0e09c49 100644
--- a/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
+++ b/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
@@ -4,28 +4,29 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{6..10} )
-
-MY_PN="${PN}.py"
-MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
+MY_P="${PN}.py-${PV}"
DESCRIPTION="ASCII quote-dot-dash to HTML entity converter"
-HOMEPAGE="https://pypi.python.org/pypi/smartypants/"
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://github.com/leohemsted/smartypants.py.git"
- EGIT_BRANCH="master"
- inherit git-r3
-else
- SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv sparc x86"
- S="${WORKDIR}/${MY_P}"
-fi
+HOMEPAGE="
+ https://pypi.org/project/smartypants/
+ https://github.com/leohemsted/smartypants.py/
+"
+SRC_URI="
+ https://github.com/leohemsted/smartypants.py/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv sparc x86"
distutils_enable_sphinx docs
-distutils_enable_tests setup.py
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s tests
+}