summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-20 01:00:40 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-20 01:14:05 +0200
commit0073fd47ffe099cd50c257d750c5bb8099613a8a (patch)
tree51658f708de5d6a91d0d629ba00a1564d7124f2c
parentapp-emacs/org-contrib: bump to 0.5 (diff)
downloadgentoo-0073fd47ffe099cd50c257d750c5bb8099613a8a.tar.gz
gentoo-0073fd47ffe099cd50c257d750c5bb8099613a8a.tar.bz2
gentoo-0073fd47ffe099cd50c257d750c5bb8099613a8a.zip
dev-scheme/racket: bump to 8.13
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-scheme/racket/Manifest2
-rw-r--r--dev-scheme/racket/racket-8.13.ebuild184
2 files changed, 186 insertions, 0 deletions
diff --git a/dev-scheme/racket/Manifest b/dev-scheme/racket/Manifest
index ffde001e3aee..66550a59fef1 100644
--- a/dev-scheme/racket/Manifest
+++ b/dev-scheme/racket/Manifest
@@ -1,2 +1,4 @@
DIST racket-8.12-src-builtpkgs.tgz 157067538 BLAKE2B 8256662e516afe8a9673e3f4874cd01ac317a7cb9c63fb26c25de4ba41664a3bec401fbefc63cc83d67023b9ad627058766ee3f699a98ebaebd4768d4d6c5f88 SHA512 4c885e2155d83bcdc6288b2af2155ad3e0e03e2b67620b11fd27eb11b8bb1ffcb58c5fa0fa322bd3fc1dce5ead3aaa0b1576f165d53d6f035830ffa42439e710
+DIST racket-8.13-src-builtpkgs.tgz 157457727 BLAKE2B ee4b2d0ebaf6118876b52cf394377e8e890feaaad593d5bb5074cac91959c44fe79e885ada3956be3b76790571244a6f3b11e6f3f2c19b138db2bf827b9c23e6 SHA512 6ab54fa5d09d0e49a65d7a268ab9e9ae2116cd303d7a62e4ff65dd8b97125fbb474bc152ab9db82616a66f37736ce8b6f7fcc195aa4cfc72141281bad08ccfb9
DIST racket-minimal-8.12-src-builtpkgs.tgz 23295791 BLAKE2B 78ef862bb7ec1e533edb0c06923047c602e25b952fe2636415d1e4da575aadb8fcad28d019958c466141c51a2072bb6af7c5bdfdae6f8b5d4581f1b3edeb5bf5 SHA512 85957b6bf90a72c700d8042776668b63fba61781e1cadcd84d636822e4ab0ae8dc9c603ba7d5027df4afb4ee0211d45eede3657f8349086958492ce981871313
+DIST racket-minimal-8.13-src-builtpkgs.tgz 23426496 BLAKE2B e35fa08cd294316607ab61fc448458e239b670eacc5bac193debbf0e16aa19d8de136c3c89d3523aacb519527dcfd25da281635395b23b58500028944408ffd1 SHA512 241fdbf75f1823a031cba76af66353fdcbdd5c34de0b673b093fbbe3fd51c0e3c297bef0717ff99d8d2a4b7eb013f450cef62362fd512cbb0f304c358811cf9d
diff --git a/dev-scheme/racket/racket-8.13.ebuild b/dev-scheme/racket/racket-8.13.ebuild
new file mode 100644
index 000000000000..3c63aec9e185
--- /dev/null
+++ b/dev-scheme/racket/racket-8.13.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit check-reqs desktop optfeature toolchain-funcs readme.gentoo-r1
+
+DESCRIPTION="General purpose, multi-paradigm Lisp-Scheme programming language"
+HOMEPAGE="https://racket-lang.org/
+ https://github.com/racket/racket/"
+SRC_URI="
+ minimal? ( https://download.racket-lang.org/installers/${PV}/${PN}-minimal-${PV}-src-builtpkgs.tgz )
+ !minimal? ( https://download.racket-lang.org/installers/${PV}/${P}-src-builtpkgs.tgz )
+"
+S="${WORKDIR}/${P}/src"
+
+# See https://blog.racket-lang.org/2019/11/completing-racket-s-relicensing-effort.html
+LICENSE="|| ( MIT Apache-2.0 ) chez? ( Apache-2.0 ) !chez? ( LGPL-3 )"
+
+# Bytecode generated by Racket is not compatible between versions.
+# The bytecode version should be denoted by SLOT, in most cases
+# PV == SLOT but this has to be checked carefully and in cases
+# where we use _p, _pre, etc it will have to be set manually.
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="+chez +doc +futures iconv +jit minimal ncurses +places +threads"
+# See bug #809785 re chez/threads
+REQUIRED_USE="chez? ( futures places ) futures? ( jit threads ) places? ( threads )"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/libffi:=
+ ncurses? (
+ sys-libs/ncurses:=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+CHECKREQS_DISK_BUILD="1700M"
+# "mred" and "mzscheme" are binaries generated by Racket, not CC
+QA_FLAGS_IGNORED="usr/bin/mred usr/bin/mzscheme"
+
+DOC_CONTENTS="
+If you wish to use sys-libs/readline instead of dev-libs/libedit
+for readline-like features in the Racket's REPL you can install
+the package 'readline-gpl' using raco, Racket's package manager
+https://pkgs.racket-lang.org/package/readline-gpl
+"
+
+# Package database files (for pkg_preinst & pkg_config)
+PKGDB=(
+ /usr/share/racket/info-cache.rktd
+ /usr/share/racket/links.rktd
+ /usr/share/racket/pkgs/pkgs.rktd
+)
+
+src_prepare() {
+ # Prepare the environment.
+ unset PLTADDONDIR PLTCOLLECTS PLTCONFIGDIR PLTUSERHOME
+
+ default
+
+ # Remove bundled libffi.
+ rm -r "${S}/bc/foreign/libffi" || die "failed to remove bundled libffi"
+}
+
+src_configure() {
+ # Compilation of Zuo does not respect the autoconf configuration.
+ tc-export CC
+
+ einfo "Configuring Zuo in ${S}/zuo"
+ pushd "${S}/zuo" >/dev/null || die
+ econf
+ popd >/dev/null || die
+
+ einfo "Configuring Racket in ${S}"
+ # Libtool:
+ # According to vapier, we should use the bundled libtool
+ # such that we don't preclude cross-compile.
+ # Thus don't use --enable-lt=/usr/bin/libtool
+ # Backend:
+ # --enable-bc builds Racket w/o chez backend
+ # C Libraries:
+ # --enable-libs & --disable-shared is the way to build
+ # .a files that are needed to embed Racket into programs
+ # https://docs.racket-lang.org/inside/cs-embedding.html
+ local -a myconf=(
+ --disable-shared
+ --disable-strip
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --enable-libs
+ $(usex chez "--enable-cs --enable-csonly" "--enable-bc --enable-bconly")
+ $(use_enable doc docs)
+ $(use_enable iconv)
+ $(use_enable ncurses curses)
+ )
+ # Some options are togglable only for the BC version (are forced in CS)
+ ! use chez && myconf+=(
+ --enable-float
+ --enable-foreign
+ --enable-gracket
+ --enable-libffi
+ $(use_enable futures)
+ $(use_enable jit)
+ $(use_enable places)
+ $(use_enable threads pthread)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ # Compile Racket.
+ CC_FOR_BUILD="$(tc-getCC)" default
+
+ # Recompile Zuo with optimizations.
+ emake -C zuo
+}
+
+src_install() {
+ # Install Racket.
+ default
+
+ # Install Zuo.
+ emake -C zuo DESTDIR="${ED}" install
+
+ # raco needs decompressed files for packages doc installation, bug #662424
+ use doc && docompress -x "/usr/share/doc/${PF}"
+
+ # Create missing desktop files and icon.
+ if ! use minimal ; then
+ newicon "${ED}/usr/share/racket/drracket-exe-icon.png" racket.png
+
+ make_desktop_entry "gracket" "GRacket" "racket" "Development;Education;"
+ make_desktop_entry "plt-games" "PLT Games" "racket" "Education;Game;"
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ # If we are merging the same SLOT check if package
+ # database files exist and do not overwrite them
+ if has_version "${CATEGORY}/${PN}:${SLOT}" ; then
+ echo "We are installing the same SLOT: ${SLOT}"
+
+ local rktd
+ for rktd in "${PKGDB[@]}" ; do
+ if [[ -f "${EROOT}/${rktd}" ]] && [[ -f "${ED}/${rktd}" ]] ; then
+ einfo "Keeping old file: ${rktd}"
+
+ mv "${ED}/${rktd}" "${ED}/${rktd}.bak" ||
+ die "failed to create a backup of ${rktd}"
+
+ cp "${EROOT}/${rktd}" "${ED}/${rktd}" ||
+ die "failed to create a copy of ${rktd}"
+ fi
+ done
+ fi
+}
+
+get_outsiders() {
+ racket -l raco -- pkg show -i | grep 'link' | sed 's|link.*||g'
+}
+
+pkg_postinst() {
+ # If we have any pkgs not included in Racket main distribution (outsiders),
+ # then we have to re-setup them or during installation other pkgs will want
+ # to recompile parts of "outsider" pkgs they depend upon (and fail).
+ local -a outsiders=( $(get_outsiders) )
+ if [[ -n "${outsiders[@]}" ]] ; then
+ ebegin "Running \"raco setup\" for outsider packages"
+ echo "Outsiders: ${outsiders[@]}"
+
+ raco setup --all-users --force --no-docs --no-user --pkgs "${outsiders[@]}"
+ eend 0 # do not fail
+ fi
+
+ optfeature "readline editing features in REPL" dev-libs/libedit
+ optfeature "generating PDF files using Scribble" dev-texlive/texlive-fontsextra
+
+ readme.gentoo_print_elog
+}