summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2020-06-22 17:41:53 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-16 17:38:41 +0300
commit008396f37bda1955855bb58d340da35984d23df7 (patch)
tree4d4e31881c49f9ecc709290eaa8b70b81aa102be
parentdev-libs/keystone: drop to maintainer-needed (diff)
downloadgentoo-008396f3.tar.gz
gentoo-008396f3.tar.bz2
gentoo-008396f3.zip
www-apps/gitea: bump to 1.11.8
Closes: https://bugs.gentoo.org/727648 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.11.8.ebuild141
2 files changed, 142 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 0caedd3fa4b8..03f07b0b5f8c 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1 +1,2 @@
DIST gitea-src-1.11.6.tar.gz 68915319 BLAKE2B 8d8fd34fe38e153aa4af932a83933d0b5ad81a63bf7b7b5be59e64dd82db3282072686979a41fafa3ac2e523f79d6926ed057b2ed18645040bf1c446c6ab04b2 SHA512 57d5214a5e05581c134d42e00ec29fe15f3245a75440fca26c7162937570affc5a2e4ba8e903cb7f15fcb271144183ce5aa473457245f36d52686ea9f1cc93b3
+DIST gitea-src-1.11.8.tar.gz 68927493 BLAKE2B 4e1b1d201848227bd5d5bfac5bbddc291e2f14d7262bb2f8353131b6284520ecda3f844e81c23e95c5cd4ef17a6414e0b3c6adf6e6be5c59f7367c19a2e549d8 SHA512 13216a4d98211eb1a5c319992c9c253ce6f7a7a343ebfdca18802eb599f7300a3c23adbba94784f70ca604751ced5aac7d663a210885554c61a24857de79b6e6
diff --git a/www-apps/gitea/gitea-1.11.8.ebuild b/www-apps/gitea/gitea-1.11.8.ebuild
new file mode 100644
index 000000000000..555b0028a9ec
--- /dev/null
+++ b/www-apps/gitea/gitea-1.11.8.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} != 9999* ]] ; then
+ SCM="golang-vcs-snapshot"
+else
+ SCM="git-r3"
+fi
+
+inherit fcaps golang-base tmpfiles systemd ${SCM}
+unset SCM
+
+EGO_PN="code.gitea.io/gitea"
+
+DESCRIPTION="A painless self-hosted Git service"
+HOMEPAGE="https://gitea.io"
+
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64"
+else
+ EGIT_REPO_URI="https://github.com/go-gitea/gitea"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}/src/${EGO_PN}"
+ has test ${FEATURES} && EGIT_MIN_CLONE_TYPE="mirror"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="+acct build-client pam sqlite"
+
+BDEPEND="<dev-lang/go-1.14.0
+ build-client? ( >=net-libs/nodejs-10[npm] )"
+DEPEND="pam? ( sys-libs/pam )"
+RDEPEND="${DEPEND}
+ acct? (
+ acct-group/git
+ acct-user/git[gitea]
+ )
+ dev-vcs/git"
+
+DOCS=( custom/conf/app.ini.sample CONTRIBUTING.md README.md )
+FILECAPS=( cap_net_bind_service+ep usr/bin/gitea )
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+PATCHES=( "${FILESDIR}/gitea-logflags.patch" )
+
+gitea_make() {
+ local gitea_tags=(
+ bindata
+ $(usev pam)
+ $(usex sqlite 'sqlite sqlite_unlock_notify' '')
+ )
+ local gitea_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
+ )
+ local makeenv=(
+ TAGS="${gitea_tags[@]}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[@]}"
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)"
+ )
+ [[ ${PV} != 9999* ]] && makeenv+=("DRONE_TAG=${PV}")
+
+ env "${makeenv[@]}" emake -j1 "$@"
+}
+
+src_prepare() {
+ default
+
+ local sedcmds=(
+ -e "s#^RUN_MODE = dev#RUN_MODE = prod#"
+ -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
+ -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
+ -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
+ -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
+ -e "s#^MODE = console#MODE = file#"
+ -e "s#^LEVEL = Trace#LEVEL = Info#"
+ -e "s#^LOG_SQL = true#LOG_SQL = false#"
+ -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
+ -e "s#^APP_ID =#;APP_ID =#"
+ -e "s#^TRUSTED_FACETS =#;TRUSTED_FACETS =#"
+ )
+
+ sed -i "${sedcmds[@]}" custom/conf/app.ini.sample || die
+ if use sqlite ; then
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.ini.sample || die
+ fi
+
+ # Remove already build assets (like frontend part)
+ use build-client && gitea_make clean-all
+}
+
+src_compile() {
+ if use build-client ; then
+ gitea_make build
+ else
+ gitea_make backend
+ fi
+}
+
+src_test() {
+ if has network-sandbox ${FEATURES}; then
+ einfo "Remove tests which are known to fail with network-sandbox enabled."
+ rm ./modules/migrations/github_test.go || die
+ fi
+
+ if [[ ${PV} != 9999* ]] ; then
+ einfo "Remove tests which depend on gitea git-repo."
+ rm ./modules/git/blob_test.go || die
+ rm ./modules/git/repo_test.go || die
+ fi
+
+ default
+}
+
+src_install() {
+ dobin gitea
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/gitea.confd-r1" gitea
+ newinitd "${FILESDIR}/gitea.initd-r3" gitea
+ newtmpfiles - gitea.conf <<-EOF
+ d /run/gitea 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/gitea.service-r2 gitea.service
+
+ insinto /etc/gitea
+ newins custom/conf/app.ini.sample app.ini
+ if use acct ; then
+ fowners root:git /etc/gitea/{,app.ini}
+ fperms g+w,o-rwx /etc/gitea/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/gitea
+ fi
+}