summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-03 17:11:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-03 19:00:42 +0200
commit00848fdc9b697c2741c535b3637fe0b77a064206 (patch)
tree8ac32c632ec0417ce7da504190493897615e4995
parentdev-python/hypothesis: Bump to 5.37.0 (diff)
downloadgentoo-00848fdc.tar.gz
gentoo-00848fdc.tar.bz2
gentoo-00848fdc.zip
dev-python/botocore: Bump to 1.18.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.18.11.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index b937cc8bc1ec..0a01421c48da 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,6 +4,7 @@ DIST botocore-1.17.63.tar.gz 6841028 BLAKE2B 89b2d5d520e733deaf3c4b68faa103e4227
DIST botocore-1.18.0.tar.gz 6838497 BLAKE2B efc0930b8ffafdf8d7f24d4f30cbf12e0dd81aa4ae405beee7663271fe8ffe680df91d40f8629b75635fae87ad29f0186e42f11e4bfebc64cc58979edd74e64b SHA512 43b5992d1ffb8d10f32f532c3085825e3775e3da4d6c25c2e300dfcd6e24967bdd318a7be37889a9d7802eb74bd9085b9642cda099b0064cbd9ffd65a56b7de5
DIST botocore-1.18.1.tar.gz 6839699 BLAKE2B 188c5a05345fc7c4d4c05b3a8d9b675b5c2141326caa62f9ae8a5a996f6c7ff4e56c581fd010afbc4c57073d7b6efd22debad3e03456f6ad0453c7f823d6409e SHA512 63a9a7ac93a8774d7a1a511da0464d7b5d0841598c7358e97343406b4d76842ca56a0187ff173e0a29d9da9ee22f94fde66f4b8c3e9c8a3fbcabdaddbe95b752
DIST botocore-1.18.10.tar.gz 6899351 BLAKE2B 4de11277fd8df8436818cd50d946e7e53191fb698a3d7bab034112445e8d66aec74dc17ed6c93bce636f29f3e455d2b08cdc56bec3a3e794d9e12e7fd5e0ccee SHA512 4a9ceaf2a0380c804b066d4c13703d4cae598c87c1f7f14b3e967a79cf829ad2e5aac39e5182db3bfff93c3289ab60571774710eee7e4ba544e20b37feb7fcc3
+DIST botocore-1.18.11.tar.gz 6903038 BLAKE2B 07115ca9106997f9185fe84ef0ce8dd415e7d3c00cddddf28302cd97ecc9a13161de3285f1a959998feb4ff3f8643d056f7ac511edfebe71d6e3267c04e3f34e SHA512 bfd6cc012df3599889979bb1771f6c37b35eec9c5b0c909ab13593764839292b044edfc9557a351e4b380b398fba2e1b169c4e7ad1b12acec07eb45efd853ace
DIST botocore-1.18.2.tar.gz 6843154 BLAKE2B 77f4cbccd6a686cfbdb2f25fafb9f2210c0e23de72fb40403f905711ec5d073b92cfd003d39406d273feb0bfb90e2ab594f2bb9c1564b5b0879efdf3bcfa47e3 SHA512 f4fec4caf3b4ebca8a593d58827fb4377c2458b7ebccb53ccd830df5423a2021ecebd534d2fe276662f8d8e91078bb5adbf611a52baa29c8ab3526d9c7b975ac
DIST botocore-1.18.3.tar.gz 6846755 BLAKE2B 3f6709cac832dff1ba07c2e8b4c235b5bcdf305c9851eedea2ce5f7847d0be93d7e9cbcb1765add47aaec1d0c1c31cdd2c88542a984af570140ffb7fe30d8388 SHA512 a8831b1549a768cea9d550dc2dc3c1c8afc03e018d2ce246569bed35cb9ce25bcb18689d066dc5b6e6dcc69db93e0b0957b32cb68c101127e01cfe3fbfa9fe08
DIST botocore-1.18.4.tar.gz 6850892 BLAKE2B 013319b1055db5a65f25b4d11c0ae97e6eb58a8976eafea98c80a33c756b8715d69fddb86c900e9c3c1a6447d05a7afd2f11a155db5f6cbcefc5f80fccbf680c SHA512 c84b7c5dcb78101d6d04bea2a4453e2c47711133bf4ee1e96c6bea18a0b3de7c41021bfe5ac501eeb2b35d50bfe8782ee29d931adf79ae77a45a2f3b117716df
diff --git a/dev-python/botocore/botocore-1.18.11.ebuild b/dev-python/botocore/botocore-1.18.11.ebuild
new file mode 100644
index 000000000000..ba67bf7ac94b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.18.11.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}