summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-01 17:02:39 -0800
committerMatt Turner <mattst88@gentoo.org>2022-03-01 17:02:45 -0800
commit0088186492c4c050ecfc1b4ea64cff27ba48cb40 (patch)
tree6a9f364a8d09472db005d73128fd6d7e0df1719b
parentsys-process/systemd-cron: remove obsolete (diff)
downloadgentoo-0088186492c4c050ecfc1b4ea64cff27ba48cb40.tar.gz
gentoo-0088186492c4c050ecfc1b4ea64cff27ba48cb40.tar.bz2
gentoo-0088186492c4c050ecfc1b4ea64cff27ba48cb40.zip
sys-process/systemd-cron: Fix version
Upstream appears to have typo'd the tag name. The VERSION and CHANGELOG files show that the version is supposed to be 1.5.18. Bug: https://bugs.gentoo.org/832053 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sys-process/systemd-cron/Manifest2
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.5.18.ebuild (renamed from sys-process/systemd-cron/systemd-cron-1.15.18.ebuild)7
2 files changed, 6 insertions, 3 deletions
diff --git a/sys-process/systemd-cron/Manifest b/sys-process/systemd-cron/Manifest
index fa6327c4f890..739e06fb5a1b 100644
--- a/sys-process/systemd-cron/Manifest
+++ b/sys-process/systemd-cron/Manifest
@@ -1,2 +1,2 @@
-DIST systemd-cron-1.15.18.tar.gz 33056 BLAKE2B a400d0169c2dcb68c91358bd2af70dca133749dab801dc87b4cdf05b8ccebe5e250466bfce93938e575aa2d832af9a4977be2f02767d2d808e45b11888277c95 SHA512 7de6a5d05ee1d73c5348ecedf6029b498b26e8cdeecce87b58f206a1719c4a90fba853eb99b860734174469c99c75a4a6fa33c13b4aac45fdc71de7f3231b9e3
DIST systemd-cron-1.5.17.tar.gz 32319 BLAKE2B 763cccebcaf98998d0e787352b4d3f2bc28a7e6ef0e800fe937fb2971a5dd8af2d9880076eadb5c3eddc23957d9b6b824b87a7a8be59c241f402ad78abed248e SHA512 20f93c108689efef5a72976509ffd567ed85dd1fada5074030018b5d560cc49f60337bdf888d1d75f6ce8b9b72e6314d754c78c19fa79d584740430e44240ef3
+DIST systemd-cron-1.5.18.tar.gz 33056 BLAKE2B a400d0169c2dcb68c91358bd2af70dca133749dab801dc87b4cdf05b8ccebe5e250466bfce93938e575aa2d832af9a4977be2f02767d2d808e45b11888277c95 SHA512 7de6a5d05ee1d73c5348ecedf6029b498b26e8cdeecce87b58f206a1719c4a90fba853eb99b860734174469c99c75a4a6fa33c13b4aac45fdc71de7f3231b9e3
diff --git a/sys-process/systemd-cron/systemd-cron-1.15.18.ebuild b/sys-process/systemd-cron/systemd-cron-1.5.18.ebuild
index cbf442435aaf..09890a45a82a 100644
--- a/sys-process/systemd-cron/systemd-cron-1.15.18.ebuild
+++ b/sys-process/systemd-cron/systemd-cron-1.5.18.ebuild
@@ -2,12 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{7,8,9,10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit python-single-r1 systemd
DESCRIPTION="systemd units to create timers for cron directories and crontab"
HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
-SRC_URI="https://github.com/systemd-cron/systemd-cron/archive/refs/tags/v${PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
+MY_PV="1.15.18"
+SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${MY_PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -27,6 +28,8 @@ DEPEND="sys-process/cronbase
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
src_prepare() {
python_fix_shebang --force "${S}/src/bin"