summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-07-27 21:46:21 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-07-29 10:47:35 +0200
commit00c17b45043326bb03a592fa604b734fc425d608 (patch)
tree85038e4a6c9390efa86b222b74fcf8ea4cfb874e
parentdev-ml/llvm-ocaml: Fix passing NDEBUG to build for LLVMDumpType() (diff)
downloadgentoo-00c17b45043326bb03a592fa604b734fc425d608.tar.gz
gentoo-00c17b45043326bb03a592fa604b734fc425d608.tar.bz2
gentoo-00c17b45043326bb03a592fa604b734fc425d608.zip
net-misc/mosh: version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--net-misc/mosh/Manifest1
-rw-r--r--net-misc/mosh/mosh-1.3.2.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-misc/mosh/Manifest b/net-misc/mosh/Manifest
index a2cfaf916e3e..64c409390aef 100644
--- a/net-misc/mosh/Manifest
+++ b/net-misc/mosh/Manifest
@@ -1,2 +1,3 @@
DIST mosh-1.2.6.tar.gz 347185 SHA256 7e82b7fbfcc698c70f5843bb960dadb8e7bd7ac1d4d2151c9d979372ea850e85 SHA512 fe53ba3ba79fb393f9fd5d3c48b2864838a1b51a8e08f0160bcfb98fc8c2363d2bb77456e1bc79b765d6489a2af54237c5423ebb88a13196a82420be0cbc7403 WHIRLPOOL b8e4f8ecce2a5bf2b7e8238ec12181aeeacabf3a1be8f153d922bda0747894e7c23ab9735824a8c163ab4d6ca7942a4aa064559b9474243b82eee3561dbbc031
DIST mosh-1.3.0.tar.gz 356220 SHA256 320e12f461e55d71566597976bd9440ba6c5265fa68fbf614c6f1c8401f93376 SHA512 2b43e3e3fb2ccf6c29a889f10dfc0d5504dbca6fabaf10419f4e355e4b73d64cc1e632324e447b25ac24ee18bb88d8a9a23f9c4824b267343fb86e26e7d5c54b WHIRLPOOL 9898ec43201e48c125a4d30d04c4045d91e66afe80e0371fdbf06d6bb775eeb3ece444cb61742e374ef29358bc75d49ae324cb7c6b89ef1bd7e440374e6a2e8f
+DIST mosh-1.3.2.tar.gz 359574 SHA256 da600573dfa827d88ce114e0fed30210689381bbdcff543c931e4d6a2e851216 SHA512 f400e8fe7ba2ab7362311fc12a00ec69587505f901988aeee500fc68d38a388218500a3f602111c883ff23a9d43572114fcf0a8bf505df203691e5b597615769 WHIRLPOOL 3d0b8ed5790103c2e12793574c19a5b4de1e8c00c9a6e81e71dfae26100743256f7fca0b9b3ef680862ffa6d4eecedc76475ab594302723cd41933698f631eeb
diff --git a/net-misc/mosh/mosh-1.3.2.ebuild b/net-misc/mosh/mosh-1.3.2.ebuild
new file mode 100644
index 000000000000..a1dac38e24f0
--- /dev/null
+++ b/net-misc/mosh/mosh-1.3.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools bash-completion-r1 eutils vcs-snapshot
+
+DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
+HOMEPAGE="http://mosh.org"
+SRC_URI="http://mosh.org/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos"
+IUSE="+client examples +mosh-hardening +server ufw +utempter"
+
+REQUIRED_USE="
+ || ( client server )
+ examples? ( client )"
+
+RDEPEND="
+ dev-libs/protobuf:0=
+ sys-libs/ncurses:0=
+ virtual/ssh
+ client? (
+ dev-lang/perl
+ dev-perl/IO-Tty
+ )
+ utempter? (
+ sys-libs/libutempter
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# [0] - avoid sandbox-violation calling git describe in Makefile.
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.5-git-version.patch
+)
+
+src_prepare() {
+ MAKEOPTS+=" V=1"
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-completion \
+ $(use_enable client) \
+ $(use_enable server) \
+ $(use_enable examples) \
+ $(use_enable ufw) \
+ $(use_enable mosh-hardening hardening) \
+ $(use_with utempter)
+}
+
+src_install() {
+ default
+
+ for myprog in $(find src/examples -type f -perm /0111) ; do
+ newbin ${myprog} ${PN}-$(basename ${myprog})
+ elog "${myprog} installed as ${PN}-$(basename ${myprog})"
+ done
+
+ # bug 477384
+ dobashcomp conf/bash-completion/completions/mosh
+}