summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-10 04:32:01 +0000
committerSam James <sam@gentoo.org>2023-01-10 04:32:45 +0000
commit00c44198aaa36a78b9f35f41d68baad8aea6caa8 (patch)
treef51cc97d5775f93c9b028a48d15aae225096d5ba
parentdev-util/rr: drop 5.6.0 (diff)
downloadgentoo-00c44198.tar.gz
gentoo-00c44198.tar.bz2
gentoo-00c44198.zip
dev-util/rr: enable py3.11, fix rr-collect-symbols.py shebang
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/rr/rr-5.6.0-r2.ebuild (renamed from dev-util/rr/rr-5.6.0-r1.ebuild)11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-util/rr/rr-5.6.0-r1.ebuild b/dev-util/rr/rr-5.6.0-r2.ebuild
index 3092495a06e7..5b243d13e78c 100644
--- a/dev-util/rr/rr-5.6.0-r1.ebuild
+++ b/dev-util/rr/rr-5.6.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{8..11} )
CMAKE_BUILD_TYPE=Release
inherit cmake linux-info python-single-r1
@@ -79,3 +79,8 @@ src_configure() {
cmake_src_configure
}
+
+src_install() {
+ cmake_src_install
+ python_fix_shebang "${ED}"/usr/bin/rr-collect-symbols.py
+}