summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-04-03 12:05:06 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2017-04-03 12:12:53 +0200
commit00d085ffb8328ae4dcc2043e32907c597d2e9fed (patch)
tree924f0c6b7b936fb2842ea8c3936184e4616433cc
parentdev-ml/ocaml-websocket: Initial import (diff)
downloadgentoo-00d085ff.tar.gz
gentoo-00d085ff.tar.bz2
gentoo-00d085ff.zip
net-misc/plowshare: 2.1.6 bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--net-misc/plowshare/Manifest1
-rw-r--r--net-misc/plowshare/plowshare-2.1.6.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/plowshare/Manifest b/net-misc/plowshare/Manifest
index 4552d99a4c9c..a1d972851173 100644
--- a/net-misc/plowshare/Manifest
+++ b/net-misc/plowshare/Manifest
@@ -1,2 +1,3 @@
DIST plowshare-2.1.3.tar.gz 91534 SHA256 2f54325158203cf64f0041b20708d47cac1f5a936f90e99aaad299cefd14757d SHA512 759110b798de36b77737cebcf19a81872b4224df8c668ffe151415f3b15be2e50843ba865185e20d20fa17affa95228085edd86e1986aa4b1f22fa4ca921eaed WHIRLPOOL e33944c69caee6062ce7e1db9bddb3b53e7613d3131497b1596947a1362635a74b2448a85a9a3f6ee908ddd6cb94e238f4ab0b9b485ed3cf10fe360fb868559d
DIST plowshare-2.1.5.tar.gz 94268 SHA256 31a1d379b738b007ff000107b03562bf73ed5f05d7fa1ebef50082f0799a59ce SHA512 1724580dd9fa818821e9686b758f904aad408c409e23e68444dbf6fc80cae81b03159fcfc816e7273777b02b1dbcc3ab93e13cc2b05f20145850a1c931da4342 WHIRLPOOL 853255b2a3abbe40349112e322e4e1bd9ca9261fe714e2d7f3802398b318a96e346238bc888eefeb78edd5050b19850b82c72050da59772ca1db0af41c14d3cb
+DIST plowshare-2.1.6.tar.gz 95946 SHA256 2823f4bc82ad9b30c0c122a312125cb923acc55ce448c56a503e03fe0a4d97c4 SHA512 bccc72f1add6389fd7fc41a27f9e169c622e3a4e7c9c1040c01a8a4569accc9b0b6910815a013d5e8aff7103ee26d943665ffeccc02db1879eca580b3892190d WHIRLPOOL 4d4204199b6dc505a2ce231c95c41f5da1e93806fc04f875844566b54da31c41baa0657f6e65fa416baf68aebbaec02a2ead0ed1baf1ac3aa314ccfb7e502226
diff --git a/net-misc/plowshare/plowshare-2.1.6.ebuild b/net-misc/plowshare/plowshare-2.1.6.ebuild
new file mode 100644
index 000000000000..52227ef820ef
--- /dev/null
+++ b/net-misc/plowshare/plowshare-2.1.6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Command-line downloader and uploader for file-sharing websites"
+HOMEPAGE="https://github.com/mcrapet/plowshare"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="bash-completion +javascript view-captcha"
+
+SRC_URI="https://github.com/mcrapet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+RDEPEND="
+ >=app-shells/bash-4
+ || ( app-text/recode ( dev-lang/perl dev-perl/HTML-Parser ) )
+ dev-vcs/git
+ net-misc/curl
+ sys-apps/util-linux
+ virtual/imagemagick-tools[tiff]
+ javascript? ( || ( dev-lang/spidermonkey:0 dev-java/rhino ) )
+ view-captcha? ( || ( media-gfx/aview media-libs/libcaca ) )"
+DEPEND=""
+
+# NOTES:
+# javascript dep should be any javascript interpreter using /usr/bin/js
+
+src_prepare() {
+ # Fix doc install path
+ sed -i -e "/^DOCDIR/s|plowshare|${PF}|" Makefile || die "sed failed"
+
+ if ! use bash-completion
+ then
+ sed -i -e \ "/^install:/s/install_bash_completion//" \
+ Makefile || die "sed failed"
+ fi
+
+ default
+}
+
+src_compile() {
+ # There is a Makefile but it's not compiling anything, let's not try.
+ :
+}
+
+src_test() {
+ # Disable tests because all of them need a working Internet connection.
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" \
+ PLOWSHARE_FORCE_VERSION="${PV}" install
+}
+
+pkg_postinst() {
+ elog "plowshare is not delivered with modules by default anymore"
+ elog "Per-user modules can be installed/updated with the plowmod command"
+ if ! use javascript; then
+ ewarn "Without javascript you will not be able to use modules"
+ ewarn "requering a Javascript shell (/usr/bin/js)"
+ fi
+}