summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:35:49 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:35:49 -0600
commit00d9fdfe24df2511709d0320de47a57a4871a65e (patch)
tree87063316c04e6c55c0cf01918a40f5050f3844d0
parentdev-python/alembic: bup (diff)
downloadgentoo-00d9fdfe.tar.gz
gentoo-00d9fdfe.tar.bz2
gentoo-00d9fdfe.zip
dev-python/taskflow: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/taskflow/Manifest1
-rw-r--r--dev-python/taskflow/taskflow-2.9.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/taskflow/Manifest b/dev-python/taskflow/Manifest
index 74bd6148af80..c0712e7dbe3e 100644
--- a/dev-python/taskflow/Manifest
+++ b/dev-python/taskflow/Manifest
@@ -1,2 +1,3 @@
DIST taskflow-1.30.0.tar.gz 1047559 SHA256 ad7aec6756b1cf26d11f1971ee50075d42024cd8b1ce4d59f469791339c3b51e SHA512 638aa8264d2402a2cc0100f7ea742e0465f2c772816b56c60508d38ac42ecd35f5a228227706f3d223320c249de910fe19866e3f4b4d27fd93c30fa9657ada58 WHIRLPOOL 7d81b340f2be1d978450d2966730a4ee3d251700b03fea48014a4a248991aadb137af728e2936436e62745cc88cb9a7879fe92bb4a2873106cdce17ffe618e35
DIST taskflow-2.6.0.tar.gz 1052292 SHA256 be3ddc948a1e0cc1d65376181dea64478b4833cc38a7552350100fa42abdee66 SHA512 b330f46f0d7b8eb91772787866c1a45a5d8feb61ac0beb5f05875190779460349ff579543202b50c66dbe59266b74b968a1a1e5a7885fd44d82ab600fd0a7033 WHIRLPOOL 03e00924d618a369d14aec1228fb4cd40ab23cb352d07d3a5e823f2ef342526825796a37ffd4423fc030638e7ee1c5f641866fec19e28b11ff3d0069837aae70
+DIST taskflow-2.9.0.tar.gz 1057334 SHA256 42b0b7bea3afeb02136e8f1b37fe0649c78aa435f100e5915e90ee6e54a97465 SHA512 1950825a5529bac7c1c0cf977e3fe5d87555fa15bde981abba85ad50af723756e6a8f090094c4dc7e0b222d0890a37a0045c6e926c23c219837b76d502d0fd02 WHIRLPOOL df6c891b0491276009ec4482bbb62c27cbfd660d11763647cfd49be5ed6d20da0cf07a407e3a8ae2627e7af63460e430387351bb0a86f9da9c439c4d0ff087eb
diff --git a/dev-python/taskflow/taskflow-2.9.0.ebuild b/dev-python/taskflow/taskflow-2.9.0.ebuild
new file mode 100644
index 000000000000..00eb85c4f025
--- /dev/null
+++ b/dev-python/taskflow/taskflow-2.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to do [jobs, tasks, flows] in a HA manner using different backends"
+HOMEPAGE="https://github.com/openstack/taskflow"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ >=dev-python/futurist-0.11.0[${PYTHON_USEDEP}]
+ !~dev-python/futurist-0.15.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/contextlib2-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.17.1[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/automaton-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/tenacity-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]"