summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-15 08:54:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-15 10:33:58 +0200
commit0108d8f7cc5a0aee756cb9da22dbbd8fb94969cd (patch)
treec55ac4614b42f7532147c6d7e794e25bb56282fb
parentwww-client/microsoft-edge-beta: remove old (diff)
downloadgentoo-0108d8f7cc5a0aee756cb9da22dbbd8fb94969cd.tar.gz
gentoo-0108d8f7cc5a0aee756cb9da22dbbd8fb94969cd.tar.bz2
gentoo-0108d8f7cc5a0aee756cb9da22dbbd8fb94969cd.zip
dev-python/botocore: Bump to 1.20.73
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.73.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 2945a6bb6185..9e1d3936fa7a 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -8,3 +8,4 @@ DIST botocore-1.20.69.tar.gz 7695769 BLAKE2B 994e5415c278a0c021deb1749c59ee5c654
DIST botocore-1.20.70.tar.gz 7700136 BLAKE2B ab7ea88763dd4637754a5d9eb955e0947efd9c5fa87856276056d6eaac341f57d5edd43ca830dd35c1283c6f41de43be2f9b06e8f328a8900cde41ec5953bf9d SHA512 d992b88df31a77b153fd3110119d1523587e98d56e4b80ac14d0c5351d76b3e4c188295fbbeafcd8efd3f414a1c0af0d78f21555b2d3285d6f8e88eefab282dc
DIST botocore-1.20.71.tar.gz 7720081 BLAKE2B 4f5d4f237222a034d2102cb637722c7d63ac34549ca582fce8d7b02a93345cc48067b195f339010a0dd47fa04a53ee4dde5f98eb58a1db3b0d4c958066717063 SHA512 7a9154efeeedc90dd9089641798494095cca9f1967e3615131af154e718081e2ce85e37fea1a729e7d7cd42d2fd6a9f79cae9409ff32aa18674a40a0e2fd0fe1
DIST botocore-1.20.72.tar.gz 7719833 BLAKE2B 23bdce05a95ebcc162e26e91923999ba50910f2fd1d78830c64ee4cb685b2f58e0f14b71c22d34973e2588590fa8af35868f696bbe7719f710baad49d7d1753d SHA512 d46cf353c1df60e24e8e3def8ccf4821bbc36366d25c073330133e4d6ebf83491c5d82dd708c14df65ebbcc08c7705fd3d1d37339742719bdaf58678e04d7824
+DIST botocore-1.20.73.tar.gz 7725102 BLAKE2B ccb41513630d8016718cba5e7cc172efb985688f8537dd7f434707f05f9222f486a42c3c84cf25edb437836f04d5ae024292a15a2e784c600bbdebf7dc34d9e3 SHA512 7b1fadcc4e337f0c7498b46cbc0779f20ceb864e2b3974c15a947f18925691ecaaf455bfd7de153d26632a2035a1f922c64320887d06203285947b4310f07e10
diff --git a/dev-python/botocore/botocore-1.20.73.ebuild b/dev-python/botocore/botocore-1.20.73.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.73.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}