summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-04 20:05:49 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-04 20:07:05 +0100
commit0109136f354cd142c832781d72c692f47e3bb351 (patch)
treeb2773aa92fe9ec52ac9e79edc18e46f02b00836c
parentsys-kernel/linux-firmware: Fix cpio dependency (diff)
downloadgentoo-0109136f354cd142c832781d72c692f47e3bb351.tar.gz
gentoo-0109136f354cd142c832781d72c692f47e3bb351.tar.bz2
gentoo-0109136f354cd142c832781d72c692f47e3bb351.zip
dev-python/gpep517: Fix tmp_path_retention_policy for tests
Closes: https://bugs.gentoo.org/923046 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/gpep517/gpep517-15.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/gpep517/gpep517-15.ebuild b/dev-python/gpep517/gpep517-15.ebuild
index e1b324df4976..5ea577490b8a 100644
--- a/dev-python/gpep517/gpep517-15.ebuild
+++ b/dev-python/gpep517/gpep517-15.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
@@ -32,6 +32,11 @@ RDEPEND="
distutils_enable_tests pytest
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o tmp_path_retention_policy=all
+}
+
python_install() {
python_domodule gpep517
python_newscript - gpep517 <<-EOF