summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-20 19:39:39 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-20 20:17:05 +0100
commit011b59bf2752d431f960d54f991d0d6e2441958f (patch)
treecfd4afdaa8cb901cd3a2915a32c058aad878736b
parentdev-python/setuptools: Bump to 69.0.0 (diff)
downloadgentoo-011b59bf2752d431f960d54f991d0d6e2441958f.tar.gz
gentoo-011b59bf2752d431f960d54f991d0d6e2441958f.tar.bz2
gentoo-011b59bf2752d431f960d54f991d0d6e2441958f.zip
dev-python/ensurepip-setuptools: Bump to 69.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ensurepip-setuptools/Manifest1
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-69.0.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/Manifest b/dev-python/ensurepip-setuptools/Manifest
index 8b38c4be8ddd..381980d0266c 100644
--- a/dev-python/ensurepip-setuptools/Manifest
+++ b/dev-python/ensurepip-setuptools/Manifest
@@ -1 +1,2 @@
DIST setuptools-68.2.2-py3-none-any.whl 807864 BLAKE2B 1ae4dab8a589c95281cac145c3e06b4027b585065a5191a9d6dd9c77730a096b592154863c555d8098c10425dfef315de3b79c6b631e8f6aacc0f234795f95fc SHA512 6e0d854040baff861e1647d2bece7d090bc793b2bd9819c56105b94090df54881a6a9b43ebd82578cd7c76d47181571b671e60672afd9def389d03c9dae84fcf
+DIST setuptools-69.0.0-py3-none-any.whl 819391 BLAKE2B 69b296d3f91a9aa35b9f01a3a9a49625677a9fc292163fbeac7e97b9ac7b2ac1a592feaf5c638705a8a586498f32adef187f24ed8f122014431a3c96f5d1c3bb SHA512 e52aeabb115aa65340b94ac4cede3c21b6a07f770fc2f17a59cc876557ee29f82d9149055b9c729b328271983bf0089f1b8392b4a77c9452bec2a0ff13cf353f
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.0.0.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.0.0.ebuild
new file mode 100644
index 000000000000..8346a1bd0f6d
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}