summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-27 22:01:00 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-28 13:16:21 +0200
commit015164abb49a7c7957b225d9a80e4e428b14ddd7 (patch)
tree417a61df1d582939f9c94562ceca4977372e97b5
parentdev-util/buildbot-pkg: add 3.4.0, enable py3.10, cleanup (diff)
downloadgentoo-015164ab.tar.gz
gentoo-015164ab.tar.bz2
gentoo-015164ab.zip
dev-util/buildbot-www: add 3.4.0, enable py3.10, cleanup
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-util/buildbot-www/Manifest1
-rw-r--r--dev-util/buildbot-www/buildbot-www-3.4.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/Manifest b/dev-util/buildbot-www/Manifest
index f48d98a0d9bd..5bd827fe84b5 100644
--- a/dev-util/buildbot-www/Manifest
+++ b/dev-util/buildbot-www/Manifest
@@ -7,3 +7,4 @@ DIST buildbot-www-3.1.0.tar.gz 3180991 BLAKE2B d2ebe82e97cb92c97c43059555c276602
DIST buildbot-www-3.1.1.tar.gz 3180995 BLAKE2B 16c6e0966d64cc6631df8b4980bb20617707ebd3fca279cc6aa614e83bf0c3537e992f120670c00992dce854304ddf421143e96565e05482bd3d231f15fbe2c6 SHA512 89a1f88958fc509e33d6d5f2e8f0690ff87069eff60296926b3cf7021a060fc3918a990e54e5750922d6152b9d1e9257a973df16630332be9fd10a3643520354
DIST buildbot-www-3.2.0.tar.gz 3182436 BLAKE2B b9ba9f0982527e5ed20e0657526292f5f9eb2ca875b6aa1944cfff6eacda2c49de6f311437d5752ab00b2391515b6d9b0caa8165cb1755b89d96489f9a0d9df0 SHA512 9cc6566cb8dd13a1031bcebcc3797cc3ced2d9fe18303a9a436854db6382ffac850ed01ad44d6bd462ed1b59264c72b06b7bb790e75f25e8e6b384ae694793b3
DIST buildbot-www-3.3.0.tar.gz 3182454 BLAKE2B 107e5563c74a647592966c22c1d3502fd72c6907efefa91de8875d4821a44f8b29a4b9c5c551a9c82980cc038fa98ce7026fd209b229ea2697515d808dcb76dc SHA512 9d332a0f70815cf7e9d3a6897f2733bd33b6938fe49cb1a879023235d159d7cd4e3faa0fca74e16a64cebe1248929a43aff0000e805011f506c4febf10b03f90
+DIST buildbot-www-3.4.0.tar.gz 3182445 BLAKE2B 350606158ae68aba1b82c43d202e6140f433905e9913c7f4fcd3f4ebd328f7b70940f0a4e76a4a1f89731f6364dd285f08052bd1d96badac4e69cd1e16643d4e SHA512 7be83f35b6042accae77db1133d54282d0d27ce15a9b34220cc015255935d7463c1a327ee289740325bbb73d6a6a162f384da2b3cc731719e7f99a911faf86cd
diff --git a/dev-util/buildbot-www/buildbot-www-3.4.0.ebuild b/dev-util/buildbot-www/buildbot-www-3.4.0.ebuild
new file mode 100644
index 000000000000..ea0de6d3f79a
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-3.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-www/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+RDEPEND="~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"