summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-10-16 15:49:49 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-10-16 15:51:09 +0200
commit0171d63fb6075caf0db45f1d26ff18556afb5ab5 (patch)
tree9b9d8cc92c888ead70c8ea977b6c69fbd51b43c7
parentUpdate remote-ids (diff)
downloadgentoo-0171d63fb6075caf0db45f1d26ff18556afb5ab5.tar.gz
gentoo-0171d63fb6075caf0db45f1d26ff18556afb5ab5.tar.bz2
gentoo-0171d63fb6075caf0db45f1d26ff18556afb5ab5.zip
dev-libs/libressl: security version bump to 2.2.4
Gentoo-Bug: 563236
-rw-r--r--dev-libs/libressl/Manifest1
-rw-r--r--dev-libs/libressl/libressl-2.2.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libressl/Manifest b/dev-libs/libressl/Manifest
index c94beec0552a..3870554ba282 100644
--- a/dev-libs/libressl/Manifest
+++ b/dev-libs/libressl/Manifest
@@ -1 +1,2 @@
DIST libressl-2.2.3.tar.gz 2967547 SHA256 a1ccc21adf91d60e99246031b99c930c9af5e1b1b5a61b1bec87beef6f16d882 SHA512 79f0cd57d2f1202e7d1213a9f9e0665bce11d1c1e5a4ba48c98b81f94e09a8c72733a5dfb0a5626b91db146641cfbec79acb9a5cbb437a60924b7f028d224500 WHIRLPOOL 1e8a49f7c491af558052257c0456b5c4d965abcfc8c7c274f7c42670f4f06a46d3e0360359fd19ecbbaf2fa461b80457e692eb2cb7b1a4bd92d0ad9a68e6663a
+DIST libressl-2.2.4.tar.gz 2966157 SHA256 6b409859be8654afc3862549494e097017e64c8d167f12584383586306ef9a7e SHA512 390fbf4f531976c873a0a1163fd57f33097686c6956ec4d3eb69e8271a4e40abfec76d65172b34ae50af8936dd8b5c3ca5fefee9d8686ca468a5577d432c3fe5 WHIRLPOOL 44d36b582efad0cff8015e507ea7c95befd5a44f2beaf69b534454cee4288681d55390a9d4c41ded8a535f0ad6c210348f365534fe3d82725e6b918a89b99e43
diff --git a/dev-libs/libressl/libressl-2.2.4.ebuild b/dev-libs/libressl/libressl-2.2.4.ebuild
new file mode 100644
index 000000000000..e3b97b5b90c2
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.2.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+SLOT="0/35" # reflects ABI of libcrypto.so and libssl.so
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}