summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-04-03 19:21:40 +0200
committerJakov Smolić <jsmolic@gentoo.org>2023-04-03 19:38:48 +0200
commit018f402dc46105a74a6eed8c2b606d9f58be2a28 (patch)
treebe67520738698523a69b0502b890b72f108ad9ec
parentapp-office/upwork: treeclean (diff)
downloadgentoo-018f402dc46105a74a6eed8c2b606d9f58be2a28.tar.gz
gentoo-018f402dc46105a74a6eed8c2b606d9f58be2a28.tar.bz2
gentoo-018f402dc46105a74a6eed8c2b606d9f58be2a28.zip
gnome-extra/gconf-editor: treeclean
Closes: https://bugs.gentoo.org/645320 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--gnome-extra/gconf-editor/Manifest1
-rw-r--r--gnome-extra/gconf-editor/files/gconf-editor-3.0.1-assertion-crash.patch34
-rw-r--r--gnome-extra/gconf-editor/files/gconf-editor-3.0.1-drop-accel.patch66
-rw-r--r--gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild34
-rw-r--r--gnome-extra/gconf-editor/metadata.xml11
-rw-r--r--profiles/package.deprecated3
-rw-r--r--profiles/package.mask1
7 files changed, 1 insertions, 149 deletions
diff --git a/gnome-extra/gconf-editor/Manifest b/gnome-extra/gconf-editor/Manifest
deleted file mode 100644
index 89dc68b16958..000000000000
--- a/gnome-extra/gconf-editor/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST gconf-editor-3.0.1.tar.xz 1452468 BLAKE2B 775072c69f3350b009c07553d178e83885379292159ea9025831bab0f6b91f2e95e341d4f654a0fd8896c560ba99e635b68f3ff825e337ec5b7d558a366fce52 SHA512 faaf237233d94730902d7c8e231545841862451f5998ef06bc3d51f6cdf0bc16bd1cecfc6b6a9e0ccc5197a06bb4f89068bfb478f900f3272ba03a2d94ec2f49
diff --git a/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-assertion-crash.patch b/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-assertion-crash.patch
deleted file mode 100644
index b7df8f51007d..000000000000
--- a/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-assertion-crash.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 25d823099337f7ede4782f46fea46f251646dc3e Mon Sep 17 00:00:00 2001
-From: Edward Sheldrake <ejsheldrake@gmail.com>
-Date: Wed, 11 Apr 2012 07:27:16 +0000
-Subject: Fix assertion failed crash
-
-Fix "assertion failed: (last_slash != NULL)" crash while navigating the
-left tree view, fixed by having the model for the right list view emit
-all the row deleted signals before deleting any of its data.
-
-Fixes https://bugzilla.gnome.org/show_bug.cgi?id=670586
----
-diff --git a/src/gconf-list-model.c b/src/gconf-list-model.c
-index 27e1af6..4fc60f8 100644
---- a/src/gconf-list-model.c
-+++ b/src/gconf-list-model.c
-@@ -133,11 +133,14 @@ gconf_list_model_set_root_path (GConfListModel *model, const gchar *root_path)
-
- if (model->root_path != NULL) {
- for (list = model->values; list; list = list->next) {
-+ model->stamp++;
-+ gtk_tree_model_row_deleted (GTK_TREE_MODEL (model), path);
-+ }
-+
-+ for (list = model->values; list; list = list->next) {
- GConfEntry *entry = list->data;
-
- g_hash_table_remove (model->key_hash, gconf_entry_get_key (entry));
-- model->stamp++;
-- gtk_tree_model_row_deleted (GTK_TREE_MODEL (model), path);
-
- gconf_entry_unref (entry);
- }
---
-cgit v0.9.2
diff --git a/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-drop-accel.patch b/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-drop-accel.patch
deleted file mode 100644
index 0d79ec56c396..000000000000
--- a/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-drop-accel.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From 62e68d8e2f6e2c473820113fbf46ced9f77111d4 Mon Sep 17 00:00:00 2001
-From: William Jon McCann <jmccann@redhat.com>
-Date: Thu, 03 May 2012 18:10:53 +0000
-Subject: Drop use GTK accel maps
-
-They are confusing, weird, and stored in an obsolete location.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=675392
----
-diff --git a/src/main.c b/src/main.c
-index 8da5ccc..9bce4b8 100644
---- a/src/main.c
-+++ b/src/main.c
-@@ -26,34 +26,6 @@
- #include "gconf-stock-icons.h"
- #include "gconf-editor-window.h"
-
--static char *
--build_accel_filename (void)
--{
-- return g_build_filename (g_get_home_dir (), ".gnome2", "accels", PACKAGE, NULL);
--}
--
--static void
--load_accel_map (void)
--{
-- char *map;
--
-- map = build_accel_filename ();
-- gtk_accel_map_load (map);
--
-- g_free (map);
--}
--
--static void
--save_accel_map (void)
--{
-- char *map;
--
-- map = build_accel_filename ();
-- gtk_accel_map_save (map);
--
-- g_free (map);
--}
--
- gint
- main (gint argc, gchar **argv)
- {
-@@ -92,7 +64,6 @@ main (gint argc, gchar **argv)
- /* Register our stock icons */
- gtk_icon_theme_append_search_path (gtk_icon_theme_get_default (), ICONDIR);
- gconf_stock_icons_register ();
-- load_accel_map ();
-
- gtk_window_set_default_icon_name ("gconf-editor");
-
-@@ -107,7 +78,6 @@ main (gint argc, gchar **argv)
-
- gtk_main ();
-
-- save_accel_map ();
- g_strfreev (remaining_args);
-
- return 0;
---
-cgit v0.9.2
diff --git a/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild b/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild
deleted file mode 100644
index d478ee8bee39..000000000000
--- a/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnome2
-
-DESCRIPTION="An editor to the GNOME config system"
-HOMEPAGE="https://gitlab.gnome.org/Archive/gconf-editor"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- >=x11-libs/gtk+-3.0.0:3
- >=gnome-base/gconf-2.12:2
-"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- app-text/gnome-doc-utils
- >=dev-util/intltool-0.35
- virtual/pkgconfig
- ~app-text/docbook-xml-dtd-4.1.2
-"
-# gnome-common for eautoreconf
-
-PATCHES=(
- # Fix assertion failed crash (from 'master')
- "${FILESDIR}/${PN}-3.0.1-assertion-crash.patch"
-
- # Drop use GTK accel maps (from 'master')
- "${FILESDIR}/${PN}-3.0.1-drop-accel.patch"
-)
diff --git a/gnome-extra/gconf-editor/metadata.xml b/gnome-extra/gconf-editor/metadata.xml
deleted file mode 100644
index dd0822fdba7b..000000000000
--- a/gnome-extra/gconf-editor/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <upstream>
- <remote-id type="gnome-gitlab">Archive/gconf-editor</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.deprecated b/profiles/package.deprecated
index 2c0ffdee4b2f..86fcec6b09a7 100644
--- a/profiles/package.deprecated
+++ b/profiles/package.deprecated
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# This file specifies packages that are considered deprecated (but not
@@ -128,7 +128,6 @@ dev-libs/libunique:1
gnome-base/gconf
gnome-base/libglade
gnome-base/libgnomecanvas
-gnome-extra/gconf-editor
media-libs/libart_lgpl
x11-libs/gtksourceview:2.0
x11-libs/libwnck:1
diff --git a/profiles/package.mask b/profiles/package.mask
index f91fc1d2cd5c..72addb42e72f 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -365,7 +365,6 @@ x11-apps/xf86dga
# Long deprecated, GNOME 2-era packages.
# Removal on 2023-04-04. Bug #873841
gnome-base/gconf
-gnome-extra/gconf-editor
# Mike Pagano <mpagano@gentoo.org> (2023-02-27)
# Mask =www-servers/nginx-unit-1.29.0-r1 for testing