summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-29 13:46:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-29 16:13:54 +0100
commit01bb620bd6a4809a5661228a2634e4d23331bb87 (patch)
tree815c4830c283f3879d9da06abc9d37cb1f0a6814
parentdev-python/black: Remove old (diff)
downloadgentoo-01bb620bd6a4809a5661228a2634e4d23331bb87.tar.gz
gentoo-01bb620bd6a4809a5661228a2634e4d23331bb87.tar.bz2
gentoo-01bb620bd6a4809a5661228a2634e4d23331bb87.zip
dev-python/executing: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/executing/Manifest2
-rw-r--r--dev-python/executing/executing-1.2.0.ebuild46
-rw-r--r--dev-python/executing/executing-2.0.0.ebuild56
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index 0d20ae828ad6..d2ce7ff6f380 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1,3 +1 @@
-DIST executing-1.2.0.gh.tar.gz 663650 BLAKE2B ba9420bfcf3805223e6b7e84d65499f3a73ef3156480586d2c5ffde4e438fcf8474f4f02c123953d04ee253de7a6a3a1b2587e57fcae546f3dae7af70a1aaa98 SHA512 c841958cc499b2d78c94570bf0556933d4a58ca5541f7a59e591be6036926ab79d5ae86bb95bbf649f3c3fb729109fe50cf04fbc72692e0cfe12edaa995ea0a6
-DIST executing-2.0.0.gh.tar.gz 837310 BLAKE2B d402a605ce80170e1789e7eec65e89da64fcbb70bbc7fcf9fb86dd6e4575312154fd969d3126ed7d88f7f9d0303304969544ad39c2161524e4157d7d1658a0bf SHA512 5c02ffafaa6993b783d013c1be0c92651af598bf872a10c3f6ea84c5e709cd1b22d9c37a778e5aaccfb05533b3c88395031c50ca722e1f780fc828256e8b201e
DIST executing-2.0.1.gh.tar.gz 837355 BLAKE2B 7d38890eb322809c2b705f51731fe7537f81a0775d99bebb4b4ae67453930daedd947b249385babbc2373969344b643f288441fc28f3588264e4ebc23e1c389d SHA512 8a753aab42ea2d3b61764ee77de3bb52ea7fcc2818298281180ffc47c7b22ee84974ee98b2137250f722ad559be92e72e8fc01d7b2d38ab6a01512618b65d4f3
diff --git a/dev-python/executing/executing-1.2.0.ebuild b/dev-python/executing/executing-1.2.0.ebuild
deleted file mode 100644
index 5079c38a00f8..000000000000
--- a/dev-python/executing/executing-1.2.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Get information about what a Python frame is currently doing"
-HOMEPAGE="
- https://github.com/alexmojaki/executing/
- https://pypi.org/project/executing/
-"
-SRC_URI="
- https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/littleutils[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- # this test explodes when collected by pytest
- "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
- epytest tests/test_pytest.py
-}
-
-pkg_postinst() {
- optfeature "getting node's source code" dev-python/asttokens
-}
diff --git a/dev-python/executing/executing-2.0.0.ebuild b/dev-python/executing/executing-2.0.0.ebuild
deleted file mode 100644
index a5e4ed0cc8c8..000000000000
--- a/dev-python/executing/executing-2.0.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Get information about what a Python frame is currently doing"
-HOMEPAGE="
- https://github.com/alexmojaki/executing/
- https://pypi.org/project/executing/
-"
-SRC_URI="
- https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/asttokens-2.1.0[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/littleutils[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local EPYTEST_DESELECT=()
- case ${EPYTHON} in
- python3.10)
- EPYTEST_DESELECT+=(
- # crashes with infinite recursion (?)
- "tests/test_main.py::test_small_samples[1656dc52edd2385921104de7bb255ca369713f4b8c034ebeba5cf946058109bc.py]"
- )
- ;;
- esac
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-pkg_postinst() {
- optfeature "getting node's source code" dev-python/asttokens
-}