summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 09:33:04 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 09:34:51 +0100
commit01bea3dda7a63cbbecc8740fd08a0d299ff5c469 (patch)
treef80917808ab5b6026d3e707808eb9a818c32315e
parentdev-python/wsproto: EAPI 8, PEP517 (diff)
downloadgentoo-01bea3dd.tar.gz
gentoo-01bea3dd.tar.bz2
gentoo-01bea3dd.zip
dev-python/defcon: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/defcon/defcon-0.10.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/defcon/defcon-0.10.0-r1.ebuild b/dev-python/defcon/defcon-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..ecf74aab0094
--- /dev/null
+++ b/dev-python/defcon/defcon-0.10.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A set of UFO based objects for use in font editing applications"
+HOMEPAGE="https://github.com/robotools/defcon"
+SRC_URI="https://github.com/robotools/defcon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/fonttools-4.28.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fs[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}