summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-28 23:10:08 +0100
committerSam James <sam@gentoo.org>2023-03-28 23:10:12 +0100
commit01bf2dc812556e94e4a06f1050c368ae5662555d (patch)
tree6c9468bdafe04082aa7016a9374e05ccff6c7e4c
parentsys-block/thin-provisioning-tools: drop obsolete ruby test deps (diff)
downloadgentoo-01bf2dc812556e94e4a06f1050c368ae5662555d.tar.gz
gentoo-01bf2dc812556e94e4a06f1050c368ae5662555d.tar.bz2
gentoo-01bf2dc812556e94e4a06f1050c368ae5662555d.zip
sys-block/thin-provisioning-tools: adapt 9999 to rustification
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-block/thin-provisioning-tools/thin-provisioning-tools-9999.ebuild55
1 files changed, 15 insertions, 40 deletions
diff --git a/sys-block/thin-provisioning-tools/thin-provisioning-tools-9999.ebuild b/sys-block/thin-provisioning-tools/thin-provisioning-tools-9999.ebuild
index 793a45aeeb38..6d318a86a818 100644
--- a/sys-block/thin-provisioning-tools/thin-provisioning-tools-9999.ebuild
+++ b/sys-block/thin-provisioning-tools/thin-provisioning-tools-9999.ebuild
@@ -1,65 +1,40 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools flag-o-matic
+inherit cargo
DESCRIPTION="A suite of tools for thin provisioning on Linux"
HOMEPAGE="https://github.com/jthornber/thin-provisioning-tools"
-if [[ ${PV} != *9999 ]]; then
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/jthornber/thin-provisioning-tools.git"
+ inherit git-r3
+else
SRC_URI="https://github.com/jthornber/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-else
- inherit git-r3
- EGIT_REPO_URI='https://github.com/jthornber/thin-provisioning-tools.git'
fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="static test"
-RESTRICT="!test? ( test )"
-
-LIB_DEPEND="dev-libs/expat[static-libs(+)]
- dev-libs/libaio[static-libs(+)]"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )
- test? (
- >=dev-cpp/gtest-1.8.0
- )
- dev-libs/boost"
-PATCHES=(
- "${FILESDIR}"/${PN}-0.7.0-build-fixes.patch
-)
+# Rust
+QA_FLAGS_IGNORED="usr/sbin/pdata_tools"
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- use static && append-ldflags -static
- local myeconfargs=(
- --prefix="${EPREFIX}"/
- --bindir="${EPREFIX}"/sbin
- --with-optimisation=''
- $(use_enable test testing)
- )
- STRIP=true econf "${myeconfargs[@]}"
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ cargo_live_src_unpack
+ else
+ default
+ fi
}
src_compile() {
emake V=
}
-src_test() {
- emake V= unit-test
-}
-
src_install() {
emake V= DESTDIR="${D}" DATADIR="${ED}/usr/share" install
- dodoc README.md TODO.org
}