summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-13 11:14:36 +0200
committerHans de Graaff <graaff@gentoo.org>2019-10-13 11:14:36 +0200
commit01ddd17cf2fc39e63afb608c6e6838bcb52794d1 (patch)
treec4e4e48e570bf2826f30a941c603d7b4f77a9e7a
parentnet-vpn/libreswan: cleanup (diff)
downloadgentoo-01ddd17c.tar.gz
gentoo-01ddd17c.tar.bz2
gentoo-01ddd17c.zip
dev-ruby/tzinfo: skip "safe" tests
We cannot guarantee that these tests will pass since they depend on the permissions of the directory hierarchy. Fixes: https://bugs.gentoo.org/693828 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/tzinfo/tzinfo-1.2.5.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-ruby/tzinfo/tzinfo-1.2.5.ebuild b/dev-ruby/tzinfo/tzinfo-1.2.5.ebuild
index 1b36cf383f93..37433640300f 100644
--- a/dev-ruby/tzinfo/tzinfo-1.2.5.ebuild
+++ b/dev-ruby/tzinfo/tzinfo-1.2.5.ebuild
@@ -29,4 +29,7 @@ ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
all_ruby_prepare() {
# Set the secure permissions that tests expect.
chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Avoid taint tests that throw SecurityErrors on newer ruby versions.
+ sed -i -e '/_info_tainted/askip"SecurityError"' test/tc_ruby_data_source.rb || die
}