summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2019-07-31 02:07:43 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-08-13 07:28:34 +0300
commit01e361c1e902c26c629d0d19eb225336a4ccd9b0 (patch)
tree60a679b39217b9565e8f56d70d90fe58f1cb0fc1
parentmedia-sound/pavucontrol-qt: Mark ~hppa too (diff)
downloadgentoo-01e361c1.tar.gz
gentoo-01e361c1.tar.bz2
gentoo-01e361c1.zip
dev-python/tqdm: bump to 4.32.2
Dependency for dev-util/conan-1.17.2 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.32.2.ebuild30
-rw-r--r--dev-python/tqdm/tqdm-9999.ebuild4
3 files changed, 33 insertions, 2 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index fc034c9de4ed..9c7f02bad2b4 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1 +1,2 @@
DIST tqdm-4.23.3.tar.gz 75941 BLAKE2B 9e5810765e8f7ea4f54b0f93f453d278d5ad4b1710f1476a6f00ff2e513789585e97dcd5a8331fe69d3593b18affd50bf9bf51cbaed29ecd68d4efad9318aa31 SHA512 40c853b7cf7611ba2ef7652417c0d42ea4392f5ea9cbe319dbb9e3dd063594e5c637fb5d13f77935fb9a034d395b28fa9480fec1c6cca1852644add4ac18cce8
+DIST tqdm-4.32.2.tar.gz 118690 BLAKE2B 21ae94fb1ba3db06f79dba021c5c68b089a64cf3cef94a7eabd30f93403fc99a69b0069d7e730e3cde965219a1762fc1d4a5db4dcf351fbf39c6176fec3caae6 SHA512 60811944f755115fe41e9c6971ee959ceeb9a7f61a4ed7ed5f16b3f2c0bc631448cc05a5f13109eb94b7f01f7bffba6267ab10e56a0f3fcd10f091f186164794
diff --git a/dev-python/tqdm/tqdm-4.32.2.ebuild b/dev-python/tqdm/tqdm-4.32.2.ebuild
new file mode 100644
index 000000000000..ae8228c5b05c
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.32.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+SRC_URI="https://github.com/tqdm/tqdm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s#man/man1#share/man/man1#" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/tqdm/tqdm-9999.ebuild b/dev-python/tqdm/tqdm-9999.ebuild
index 8e669e8670df..b269ad3ec5c9 100644
--- a/dev-python/tqdm/tqdm-9999.ebuild
+++ b/dev-python/tqdm/tqdm-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1 git-r3